aboutsummaryrefslogtreecommitdiffstats
path: root/www/ocaml-net
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-05-16 19:36:49 +0800
committermarino <marino@FreeBSD.org>2015-05-16 19:36:49 +0800
commit6f35725ec62c262ec2b286d73ba93c2d986fe95a (patch)
tree19e996ea90506821382098915aceddb80518b7d6 /www/ocaml-net
parent50f2451524967f72aeeb740ab0eddbd683b9cf32 (diff)
downloadfreebsd-ports-gnome-6f35725ec62c262ec2b286d73ba93c2d986fe95a.tar.gz
freebsd-ports-gnome-6f35725ec62c262ec2b286d73ba93c2d986fe95a.tar.zst
freebsd-ports-gnome-6f35725ec62c262ec2b286d73ba93c2d986fe95a.zip
www/ocamlnet: Upgrade version 3.7.4 => 4.0.3 to unbreak
Several options were removed / changed / added. I maintained as many as I could, but did not add new ones e.g. gnutls which probably requires another ocaml package. Somebody that needs more options than this needs to adopt the port and support them. This port broke with the latest ocaml, so upgrading was necessary to fix the build.
Diffstat (limited to 'www/ocaml-net')
-rw-r--r--www/ocaml-net/Makefile45
-rw-r--r--www/ocaml-net/distinfo4
-rw-r--r--www/ocaml-net/files/patch-Makefile.rules (renamed from www/ocaml-net/files/patch-Makefile)7
3 files changed, 11 insertions, 45 deletions
diff --git a/www/ocaml-net/Makefile b/www/ocaml-net/Makefile
index b6cd6be75e1c..a3d3363ebd2a 100644
--- a/www/ocaml-net/Makefile
+++ b/www/ocaml-net/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= net
-PORTVERSION= 3.7.3
+PORTVERSION= 4.0.3
CATEGORIES= www
MASTER_SITES= http://download.camlcity.org/download/
PKGNAMEPREFIX= ocaml-
@@ -41,50 +41,29 @@ PORTEXAMPLES= *
OCAML_PKGDIRS= netsys netshm equeue shell netstring rpc-generator \
rpc pop smtp netclient netcgi2 netgssapi netplex \
netcgi2-plex netcamlbox netmulticore rpc-auth-local \
- netstring-pcre
+ netstring-pcre netunidata
OCAML_LDLIBS= ${OCAML_PKGDIRS:S/^/${OCAML_SITELIBDIR}\//}
-OPTIONS_DEFINE= SSL NETHTTPD AUTH_DH GTK2 APACHE ZIP SCRAM EXAMPLES DOCS
-OPTIONS_DEFAULT=SSL
-AUTH_DH_DESC= Diffie-Hellman authorization support
+OPTIONS_DEFINE= NETHTTPD GTK2 APACHE ZIP EXAMPLES DOCS
+OPTIONS_DEFAULT=
NETHTTPD_DESC= Integrated HTTP daemon
-SCRAM_DESC= SCRAM support
ZIP_DESC= Compression support
APACHE_DESC= Apache mod connector (experimental)
CONFIGURE_ARGS+=-disable-gtk \
-enable-pcre
-SSL_BUILD_DEPENDS= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
-SSL_RUN_DEPENDS= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
-
-AUTH_DH_BUILD_DEPENDS= ${SA_DIR}/cryptgps/cryptgps.a:${PORTSDIR}/security/ocaml-cryptgps
-AUTH_DH_RUN_DEPENDS= ${SA_DIR}/cryptgps/cryptgps.a:${PORTSDIR}/security/ocaml-cryptgps
-
GTK2_BUILD_DEPENDS= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
GTK2_RUN_DEPENDS= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
ZIP_BUILD_DEPENDS= ${SA_DIR}/zip/zip.a:${PORTSDIR}/archivers/ocaml-zip
ZIP_RUN_DEPENDS= ${SA_DIR}/zip/zip.a:${PORTSDIR}/archivers/ocaml-zip
-SCRAM_BUILD_DEPENDS= ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
-SCRAM_RUN_DEPENDS= ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
-
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSSL}
-CONFIGURE_ARGS+= -enable-ssl
-OCAML_PKGDIRS+= equeue-ssl rpc-ssl
-.endif
-
.if ${PORT_OPTIONS:MNETHTTPD}
CONFIGURE_ARGS+= -with-nethttpd
-OCAML_PKGDIRS+= nethttpd nethttpd-for-netcgi2
-.endif
-
-.if ${PORT_OPTIONS:MAUTH_DH}
-CONFIGURE_ARGS+= -with-rpc-auth-dh
-OCAML_PKGDIRS+= rpc-auth-dh
+OCAML_PKGDIRS+= nethttpd
.endif
.if ${PORT_OPTIONS:MGTK2}
@@ -95,7 +74,7 @@ OCAML_PKGDIRS+= equeue-gtk2
.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE= 22+
CONFIGURE_ARGS+= -enable-apache -apxs ${APXS} -apache ${HTTPD}
-OCAML_PKGDIRS+= netcgi_apache
+OCAML_PKGDIRS+= netcgi2-apache
.endif
.if ${PORT_OPTIONS:MZIP}
@@ -103,18 +82,8 @@ CONFIGURE_ARGS+= -enable-zip
OCAML_PKGDIRS+= netzip
.endif
-.if ${PORT_OPTIONS:MSCRAM}
-CONFIGURE_ARGS+= -enable-crypto
-OCAML_PKGDIRS+= netmech-scram
-.endif
-
post-patch:
- ${REINPLACE_CMD} -e '/\.libs/d' \
- ${WRKSRC}/src/netcgi2-apache/Makefile.def
- ${REINPLACE_CMD} -e 's/camlzip/zip/' \
- ${WRKSRC}/configure \
- ${WRKSRC}/src/netzip/META.in \
- ${WRKSRC}/src/netzip/Makefile
+ @${REINPLACE_CMD} -e 's/camlzip/zip/' ${WRKSRC}/configure
post-install:
.if ${PORT_OPTIONS:MDOCS}
diff --git a/www/ocaml-net/distinfo b/www/ocaml-net/distinfo
index 0cdcecd2e487..c036637378b5 100644
--- a/www/ocaml-net/distinfo
+++ b/www/ocaml-net/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ocamlnet-3.7.3.tar.gz) = 4ddc6928856d57b613de8889708f04a7bba04571b7bf1c525418cf9e3d8b4468
-SIZE (ocamlnet-3.7.3.tar.gz) = 3352779
+SHA256 (ocamlnet-4.0.3.tar.gz) = d3b030715fe2c5f395ff9c08f0a8d3baa8830161300ba29e5aa8fabb92b182c1
+SIZE (ocamlnet-4.0.3.tar.gz) = 4334416
diff --git a/www/ocaml-net/files/patch-Makefile b/www/ocaml-net/files/patch-Makefile.rules
index 28913053ebe5..d67668fdbba6 100644
--- a/www/ocaml-net/files/patch-Makefile
+++ b/www/ocaml-net/files/patch-Makefile.rules
@@ -1,9 +1,6 @@
-$NetBSD: patch-Makefile.rules,v 1.1 2012/07/06 09:29:14 wiz Exp $
-
-make package work with DESTDIR support
---- Makefile.rules.orig 2012-02-29 18:02:51.000000000 +0000
+--- Makefile.rules.orig 2015-04-26 23:27:28 UTC
+++ Makefile.rules
-@@ -148,7 +148,8 @@ realuninstall: $(UNINSTOTHER) uninstall-
+@@ -155,7 +155,8 @@ realuninstall: $(UNINSTOTHER) uninstall-
.PHONY: install-findlib
install-findlib: META
files=`$(COLLECT_FILES) *.mli *.cmi *.cma *.cmxa *.a dll* META $(INSTALL_EXTRA)` && \