aboutsummaryrefslogtreecommitdiffstats
path: root/www/ocaml-net
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-04-09 03:21:34 +0800
committerstas <stas@FreeBSD.org>2008-04-09 03:21:34 +0800
commit7922e81cdbea018fe006015ba71f9aaa9c45d810 (patch)
tree11a98c3a8b58d94d3c35976d77f87f890d5938c6 /www/ocaml-net
parenta9b666fc9b35d6eb38c294801b034091cd77fcc8 (diff)
downloadfreebsd-ports-gnome-7922e81cdbea018fe006015ba71f9aaa9c45d810.tar.gz
freebsd-ports-gnome-7922e81cdbea018fe006015ba71f9aaa9c45d810.tar.zst
freebsd-ports-gnome-7922e81cdbea018fe006015ba71f9aaa9c45d810.zip
- Update ocaml-net to 2.2.9
- make PREFIX-clean - use bsd.ocamk.mk framework - update pkg description - pass maintainership to submitter. PR: ports/118888 (based on) Submitted by: manfred.lotz@yahoo.de
Diffstat (limited to 'www/ocaml-net')
-rw-r--r--www/ocaml-net/Makefile80
-rw-r--r--www/ocaml-net/distinfo6
-rw-r--r--www/ocaml-net/pkg-deinstall5
-rw-r--r--www/ocaml-net/pkg-descr25
-rw-r--r--www/ocaml-net/pkg-install5
5 files changed, 46 insertions, 75 deletions
diff --git a/www/ocaml-net/Makefile b/www/ocaml-net/Makefile
index c2e269532d71..dd4478feabc1 100644
--- a/www/ocaml-net/Makefile
+++ b/www/ocaml-net/Makefile
@@ -6,79 +6,57 @@
#
PORTNAME= net
-PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTVERSION= 2.2.9
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ocamlnet
PKGNAMEPREFIX= ocaml-
DISTNAME= ocaml${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= manfred.lotz@yahoo.de
COMMENT= OCaml modules for Internet applications
-BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
- ${LOCALBASE}/lib/ocaml/site-lib/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
-RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- ${LOCALBASE}/lib/ocaml/site-lib/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
+BUILD_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
+RUN_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
-.if !defined(WITHOUT_NETHTTPD)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/ocaml/site-lib/equeue/equeue.a:${PORTSDIR}/devel/ocaml-equeue
-RUN_DEPENDS+= ${LOCALBASE}/lib/ocaml/site-lib/equeue/equeue.a:${PORTSDIR}/devel/ocaml-equeue
-.endif
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
+CONFLICTS= ocaml-equeue-2* ocaml-netclient-0*
USE_GMAKE= yes
-
+USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
HAS_CONFIGURE= yes
-# seems required to build www/ocaml-wdialog:
-CONFIGURE_ARGS+= -enable-compatcgi
ALL_TARGET= all opt
-.if !defined(NOPORTDOCS)
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+PLIST_FILES= bin/netplex-admin \
+ bin/ocamlrpcgen
+
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PKGNAMEPREFIX}${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PKGNAMEPREFIX}${PORTNAME}
+SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
+.if !defined(NOPORTDOCS)
PORTDOCS= *
+PORTEXAMPLES= *
.endif
+OCAML_PKGDIRS= netsys netshm equeue shell netstring rpc-generator \
+ rpc pop smtp netclient netcgi1 netcgi2 cgi netplex \
+ netcgi2-plex
+
post-install:
- @${FIND} ${PREFIX}/lib/ocaml/site-lib/cgi -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/cgi" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ocamlfind remove cgi 2>/dev/null || true" >> ${TMPPLIST}
- @${FIND} ${PREFIX}/lib/ocaml/site-lib/netstring -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/netstring" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ocamlfind remove netstring 2>/dev/null || true" >> ${TMPPLIST}
- @${FIND} ${PREFIX}/lib/ocaml/site-lib/pop -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/pop" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ocamlfind remove pop 2>/dev/null || true" >> ${TMPPLIST}
- @${FIND} ${PREFIX}/lib/ocaml/site-lib/smtp -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/smtp" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ocamlfind remove smtp 2>/dev/null || true" >> ${TMPPLIST}
-.if !defined(WITHOUT_NETHTTPD)
- @${FIND} ${PREFIX}/lib/ocaml/site-lib/nethttpd -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/nethttpd" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ocamlfind remove nethttpd 2>/dev/null || true" >> ${TMPPLIST}
-.endif
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/../doc/ ${DOCSDIR}
- @${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/../examples/ ${EXAMPLESDIR}
- @${CHMOD} -R +r ${EXAMPLESDIR}
- @${FIND} ${EXAMPLESDIR} -type f | \
+.for pkg in ${OCAMLNET_PACKAGES}
+ @${FIND} ${PREFIX}/lib/ocaml/site-lib/${pkg} -type f | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${EXAMPLESDIR} -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/
+ @(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${DOCSDIR}/)
+
+ @${MKDIR} ${EXAMPLESDIR}/
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
.endif
.include <bsd.port.mk>
diff --git a/www/ocaml-net/distinfo b/www/ocaml-net/distinfo
index 4cbdda8b3d7d..354747b7f3e6 100644
--- a/www/ocaml-net/distinfo
+++ b/www/ocaml-net/distinfo
@@ -1,3 +1,3 @@
-MD5 (ocamlnet-1.1.1.tar.gz) = 4347d04ae16e69b61940f8679eeeef07
-SHA256 (ocamlnet-1.1.1.tar.gz) = ce9a88a2597e0ea5a3b164979e56bd3f8a02d3277fb8830e16be4b9d3b474be1
-SIZE (ocamlnet-1.1.1.tar.gz) = 793905
+MD5 (ocamlnet-2.2.9.tar.gz) = 3655e3be3bb2806e0a1f48bb7ce16fb3
+SHA256 (ocamlnet-2.2.9.tar.gz) = 134530a4357879e095bdbbb5f21f78634a16ef4d787eb151676b7fee7e4c0dc9
+SIZE (ocamlnet-2.2.9.tar.gz) = 1877257
diff --git a/www/ocaml-net/pkg-deinstall b/www/ocaml-net/pkg-deinstall
deleted file mode 100644
index 618dddd13f00..000000000000
--- a/www/ocaml-net/pkg-deinstall
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-mv ${PKG_PREFIX}/lib/ocaml/ld.conf ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
-grep -v netstring ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp > ${PKG_PREFIX}/lib/ocaml/ld.conf
-rm -f ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
diff --git a/www/ocaml-net/pkg-descr b/www/ocaml-net/pkg-descr
index eb220b5c8717..442134729b19 100644
--- a/www/ocaml-net/pkg-descr
+++ b/www/ocaml-net/pkg-descr
@@ -1,18 +1,21 @@
A collection of modules for the Objective Caml language which focus
on application-level Internet protocols and conventions.
-The current distribution contains:
+Ocamlnet consists of a number of libraries:
-- a mature implementation of the CGI protocol
-
-- an implementation of the JSERV protocol (AJP-1.2)
-
-- an experimental POP3 client
-
-- a library of string processing functions related to Internet
- protocols
+ * netstring is about processing strings that occur in network context
+ * netcgi1 and netcgi2 focus on portable web applications
+ * nethttpd is a web server component (HTTP server implementation)
+ * netplex is a generic server framework
+ * rpc implements OncRPC
+ * netclient implements clients for HTTP, FTP, and Telnet
+ * equeue is an event queue used for many protocol implementations
+ * shell is about calling external commands
+ * netshm provides shared memory for IPC purposes
+ * netsys contains bindings for system functions
+ * smtp and pop are two further client implementations
WWW: http://sourceforge.net/projects/ocamlnet
-- Stephane Legrand
- <stephane@freebsd.org>
+- Manfred Lotz
+ <manfred.lotz@yahoo.de>
diff --git a/www/ocaml-net/pkg-install b/www/ocaml-net/pkg-install
deleted file mode 100644
index b552ac043ee0..000000000000
--- a/www/ocaml-net/pkg-install
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-if ! grep "${PKG_PREFIX}/lib/ocaml/site-lib/netstring" ${PKG_PREFIX}/lib/ocaml/ld.conf >/dev/null 2>&1; then
- echo "${PKG_PREFIX}/lib/ocaml/site-lib/netstring" >> ${PKG_PREFIX}/lib/ocaml/ld.conf
-fi