aboutsummaryrefslogtreecommitdiffstats
path: root/www/ojs2
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-03-29 05:02:50 +0800
committerjgh <jgh@FreeBSD.org>2012-03-29 05:02:50 +0800
commit3a7ddc3fe4b1895f0a51d6e9a0af9ebdc9d9ba0c (patch)
treed06cbb659f33d79e51562284ae8b1149997455f2 /www/ojs2
parentef37fe5772a14b3b55e098c167c0145adc0124bf (diff)
downloadfreebsd-ports-gnome-3a7ddc3fe4b1895f0a51d6e9a0af9ebdc9d9ba0c.tar.gz
freebsd-ports-gnome-3a7ddc3fe4b1895f0a51d6e9a0af9ebdc9d9ba0c.tar.zst
freebsd-ports-gnome-3a7ddc3fe4b1895f0a51d6e9a0af9ebdc9d9ba0c.zip
- drop invalid post-deinstall target
- add de-install script PR: ports/166097 Submitted by: jgh Approved by: maintainer timeout ( 14 days ) Feature safe: yes
Diffstat (limited to 'www/ojs2')
-rw-r--r--www/ojs2/Makefile5
-rw-r--r--www/ojs2/files/pkg-deinstall.in5
-rw-r--r--www/ojs2/pkg-plist3
3 files changed, 8 insertions, 5 deletions
diff --git a/www/ojs2/Makefile b/www/ojs2/Makefile
index 5e76df53890b..9611308e6968 100644
--- a/www/ojs2/Makefile
+++ b/www/ojs2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ojs2
PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://pkp.sfu.ca/ojs/download/ \
http://socpvs.org/pkp/ \
@@ -72,6 +73,7 @@ DOCS= docs
.endif
PLIST_SUB+= ECHO_MSG=${ECHO_MSG}
+SUB_FILES= pkg-deinstall
do-install:
@cd ${WRKSRC} && ${COPYTREE_SHARE} "${NONDOCS}" ${WWWDIR}
@@ -97,7 +99,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-post-deinstall:
- @${RM} -rf ${WWWDIR}/cache
-
.include <bsd.port.post.mk>
diff --git a/www/ojs2/files/pkg-deinstall.in b/www/ojs2/files/pkg-deinstall.in
new file mode 100644
index 000000000000..5dc2ea7823b2
--- /dev/null
+++ b/www/ojs2/files/pkg-deinstall.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ /bin/rm -rf %%WWWDIR%%/cache
+fi
diff --git a/www/ojs2/pkg-plist b/www/ojs2/pkg-plist
index 9aadca974e21..7c6b00088f6b 100644
--- a/www/ojs2/pkg-plist
+++ b/www/ojs2/pkg-plist
@@ -1,5 +1,4 @@
@exec mkdir -p %D/%%WWWDIR%%/cache/_db
-%%WWWDIR%%/cache/fc-locale-list.php
@exec mkdir -p %D/%%WWWDIR%%/cache/t_cache
@exec mkdir -p %D/%%WWWDIR%%/cache/t_compile
@exec mkdir -p %D/%%WWWDIR%%/cache/t_config
@@ -4345,5 +4344,5 @@
@unexec /bin/rm -rf %D/%%WWWDIR%%/cache/t_compile 2>/dev/null || true
@unexec /bin/rm -rf %D/%%WWWDIR%%/cache/t_cache 2>/dev/null || true
@unexec /bin/rm -rf %D/%%WWWDIR%%/cache/_db 2>/dev/null || true
-@dirrm %%WWWDIR%%/cache
+@dirrmtry %%WWWDIR%%/cache
@dirrm %%WWWDIR%%