aboutsummaryrefslogtreecommitdiffstats
path: root/www/openvrml
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
committerJeremy Messenger <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
commit15b6544926b07a98710eeb765baf03e3fc9a195c (patch)
tree35103cf986d2ed2295c97768e62afcc47dfed877 /www/openvrml
parent23fcf54562404bb41380488c8318ac0e3ce15efc (diff)
downloadfreebsd-ports-gnome-15b6544926b07a98710eeb765baf03e3fc9a195c.tar.gz
freebsd-ports-gnome-15b6544926b07a98710eeb765baf03e3fc9a195c.tar.zst
freebsd-ports-gnome-15b6544926b07a98710eeb765baf03e3fc9a195c.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'www/openvrml')
-rw-r--r--www/openvrml/Makefile8
-rw-r--r--www/openvrml/pkg-plist5
2 files changed, 8 insertions, 5 deletions
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index dafe6038c952..a8fc43b06a25 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openvrml
PORTVERSION= 0.17.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -38,7 +38,8 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
USE_GECKO= firefox seamonkey
-PLIST_SUB= PLUGINS_DIR=${BROWSER_PLUGINS_DIR:S|^${LOCALBASE}/||}
+USE_WEBPLUGINS= native
+WEBPLUGINS_FILES=openvrml.so
.if !defined(NOPORTDOCS)
PORTDOCS= *
@@ -46,6 +47,7 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
.if ${OSVERSION} < 700042
BROKEN= Does not compile
@@ -79,7 +81,7 @@ pre-configure:
"/hardcode_libdir_flag_spec/s|\(=.\)\(.*\)\(\$$libdir\)|& \2${JAVA_HOME}/jre/lib/${ARCH}/client|" \
${WRKSRC}/${cfg}
.endfor
- ${REINPLACE_CMD} -e 's|$$(libdir)/mozilla/plugins|${BROWSER_PLUGINS_DIR}|' \
+ ${REINPLACE_CMD} -e 's|$$(libdir)/mozilla/plugins|${WEBPLUGINS_DIR}|' \
${WRKSRC}/mozilla-plugin/src/Makefile.in
.if ${GECKO} != "firefox"
${REINPLACE_CMD} -e "s|FIREFOX_JS|${GECKO:U}_JS|g;s|firefox-js|${GECKO}-js|" \
diff --git a/www/openvrml/pkg-plist b/www/openvrml/pkg-plist
index 5c6e7f8a7b21..6a4633704938 100644
--- a/www/openvrml/pkg-plist
+++ b/www/openvrml/pkg-plist
@@ -43,8 +43,8 @@ lib/libopenvrml-gl.so.7
lib/libopenvrml.a
lib/libopenvrml.so
lib/libopenvrml.so.8
-%%PLUGINS_DIR%%/openvrml.la
-%%PLUGINS_DIR%%/openvrml.so
+%%WEBPLUGINS_DIR%%/openvrml.la
+%%WEBPLUGINS_DIR%%/openvrml.so
libdata/pkgconfig/openvrml-gl.pc
libdata/pkgconfig/openvrml.pc
libexec/openvrml-xembed
@@ -69,6 +69,7 @@ libexec/openvrml-xembed
share/openvrml-player/glade/openvrml-player.glade
@dirrm share/openvrml-player/glade
@dirrm share/openvrml-player
+@dirrmtry %%WEBPLUGINS_DIR%%
@dirrm include/openvrml/openvrml/gl
@dirrm include/openvrml/openvrml
@dirrm include/openvrml