aboutsummaryrefslogtreecommitdiffstats
path: root/www/opera-devel/Makefile
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-08-20 14:44:24 +0800
committerdaichi <daichi@FreeBSD.org>2003-08-20 14:44:24 +0800
commit633bfdcda673ef1d6777dcf419441ffc2b3daf91 (patch)
tree8c1103d3054c7bcc185cc8df7384a8b9188e5bca /www/opera-devel/Makefile
parent5e49e1c0c2bfe5d28aa650048ddc50c35e0ca9fd (diff)
downloadfreebsd-ports-gnome-633bfdcda673ef1d6777dcf419441ffc2b3daf91.tar.gz
freebsd-ports-gnome-633bfdcda673ef1d6777dcf419441ffc2b3daf91.tar.zst
freebsd-ports-gnome-633bfdcda673ef1d6777dcf419441ffc2b3daf91.zip
update www/opera: 6.12.20030305 -> 7.20.20030811 and take maintainership
PR: 55509 Submitted by: Arjan van Leeuwen <avleeuwen@piwebs.com>
Diffstat (limited to 'www/opera-devel/Makefile')
-rw-r--r--www/opera-devel/Makefile65
1 files changed, 55 insertions, 10 deletions
diff --git a/www/opera-devel/Makefile b/www/opera-devel/Makefile
index bca98e522590..266c063941b2 100644
--- a/www/opera-devel/Makefile
+++ b/www/opera-devel/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= opera
-PORTVERSION= 6.12.20030305
+PORTVERSION= 7.20.20030811
CATEGORIES= www
-MASTER_SITES= http://opera.online.no/unix/freebsd/612/final/en/static/ \
- ftp://ftp.opera.com/pub/opera/unix/freebsd/612/final/en/static/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/12./12-/}.1-static-qt.i386.freebsd
+MASTER_SITES= http://snapshot.opera.com/unix/intel-freebsd/438-20030811-7.20-B3/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/0./0-/}.1-static-qt.i386.freebsd
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= avleeuwen@piwebs.com
COMMENT= A blazingly fast, full-featured, standards-compliant browser
RESTRICTED= "not redistributable; commercial software"
@@ -20,19 +19,65 @@ RESTRICTED= "not redistributable; commercial software"
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
-USE_XLIB= yes
NO_BUILD= yes
NO_FILTER_SHLIBS=yes
-do-install:
- cd ${WRKSRC} && ${SH} install.sh --prefix="${PREFIX}"
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
+LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif
+.if exists(/etc/X11/applnk)
+PLIST_SUB+= APPLNK:=""
+.else
+PLIST_SUB+= APPLNK:="@comment "
+.endif
+
+.if exists(${X11BASE}/share/gnome)
+PLIST_SUB+= GNOME:=""
+.else
+PLIST_SUB+= GNOME:="@comment "
+.endif
+
+.if exists(${X11BASE}/share/applnk/Internet)
+PLIST_SUB+= KDE:=""
+.else
+PLIST_SUB+= KDE:="@comment "
+.endif
+
+.if exists(${X11BASE}/share/applnk/Networking)
+PLIST_SUB+= KDE2:=""
+.else
+PLIST_SUB+= KDE2:="@comment "
+.endif
+
+.if exists(${X11BASE}/share/gnome/apps)
+PLIST_SUB+= GNOMELNK:=""
+.else
+PLIST_SUB+= GNOMELNK:="@comment "
+.endif
+
+pre-everything:
+ @${ECHO_MSG} '===> **************************************************'
+ @${ECHO_MSG} '===> NOTE: The native version of Opera can not be'
+ @${ECHO_MSG} '===> installed at the same time as linux-opera. If you'
+ @${ECHO_MSG} '===> already have www/linux-opera installed, we'
+ @${ECHO_MSG} '===> recommend you press Ctrl-C now and deinstall it.'
+ @${ECHO_MSG} '===> **************************************************'
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%X11PREFIX%%|${X11BASE}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/install.sh
+
+do-install:
+ (cd ${WRKSRC} && ./install.sh --prefix=${PREFIX})
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>