aboutsummaryrefslogtreecommitdiffstats
path: root/www/opera
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2014-09-06 18:59:27 +0800
committerak <ak@FreeBSD.org>2014-09-06 18:59:27 +0800
commit5fa74b314964cfe76f5161a8a79f304500d57b87 (patch)
treef54e244803846d5bbf051c2b813209ee1ba94eda /www/opera
parent8e389c1fd3121a984241f04d7231b009da8616e2 (diff)
downloadfreebsd-ports-gnome-5fa74b314964cfe76f5161a8a79f304500d57b87.tar.gz
freebsd-ports-gnome-5fa74b314964cfe76f5161a8a79f304500d57b87.tar.zst
freebsd-ports-gnome-5fa74b314964cfe76f5161a8a79f304500d57b87.zip
- Use options helpers
- Remove LIBSTDCXX options - Set INSTALLS_ICONS only if gnome is used - Remove unnecessary bsd.port.{pre,post}.mk inclusion - Mute REINPLACE_CMD commands - Don't try to remove etc/libmap.d, it's owned by the mtree
Diffstat (limited to 'www/opera')
-rw-r--r--www/opera/Makefile63
-rw-r--r--www/opera/files/patch-opera7
-rw-r--r--www/opera/pkg-descr2
-rw-r--r--www/opera/pkg-plist2
4 files changed, 31 insertions, 43 deletions
diff --git a/www/opera/Makefile b/www/opera/Makefile
index f7e88307ff0f..dbca00d027f5 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -2,7 +2,7 @@
PORTNAME= opera
PORTVERSION= ${OPERA_VER}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.opera.com/pub/opera/${MASTER_SITES_VER_PATH}/ \
ftp://opera.inode.at/${MASTER_SITES_VER_PATH}/ \
@@ -22,33 +22,32 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
BUILD_DEPENDS= ${LOCALBASE}/bin/update-mime-database:${PORTSDIR}/misc/shared-mime-info
RUN_DEPENDS= ${LOCALBASE}/bin/update-mime-database:${PORTSDIR}/misc/shared-mime-info
+ONLY_FOR_ARCHS= i386 amd64
+
OPERA_VER?= 12.16
OPERA_BUILD?= 1860
MASTER_SITES_VER_PATH= unix/${OPERA_VER:S/.//}
USES= tar:xz desktop-file-utils shared-mime-info
USE_XORG= x11 xext sm ice xft xrender
-INSTALLS_ICONS= yes
REINPLACE_ARGS= -i '' # no .bak files
-NO_BUILD= yes
EXPLICIT_PACKAGE_DEPENDS= yes
WEBPLUGIN_SUBDIR= ${LOCALBASE}/lib/browser_plugins/symlinks/opera
OPTIONS_DEFINE= CUPS VIDEO GTK2 KDE4
-OPTIONS_SINGLE= LIBSTDCXX
-OPTIONS_SINGLE_LIBSTDCXX= COMPAT9 GCCXX GCC46
-OPTIONS_DEFAULT= CUPS VIDEO COMPAT9
+OPTIONS_DEFAULT= CUPS VIDEO
NO_OPTIONS_SORT=yes
CUPS_DESC= support for printing (requires CUPS)
VIDEO_DESC= support for HTML5 video (requires GStreamer)
-COMPAT9_DESC= use libstdc++.so.6 from compat9x
-GCCXX_DESC= use libstdc++.so.6 from lang/gcc
-GCC46_DESC= use libstdc++.so.6 from lang/gcc46
CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
+VIDEO_USE= gstreamer=vorbis,ogg,theora,vp8,good
+GTK2_USE= gnome=gtk20,libxml2
+KDE4_USE= kde4=kdelibs
+
.include <bsd.port.options.mk>
.if defined(FETCH_ALL)
@@ -62,64 +61,46 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
.endif
.endif
-.if ${PORT_OPTIONS:MVIDEO}
-USE_GSTREAMER+= vorbis ogg theora vp8 good
-.endif
-
.if ${PORT_OPTIONS:MGTK2}
-USE_GNOME+= gtk20 libxml2
-.endif
-
-.if ${PORT_OPTIONS:MKDE4}
-USE_KDE4+= kdelibs
+INSTALLS_ICONS= yes
.endif
-.include <bsd.port.pre.mk>
-
-ONLY_FOR_ARCHS= i386 amd64
-
OPERA_ARCH= ${ARCH:S,i386,intel,}
.if ${OSVERSION} >= 1000054
-.if ${PORT_OPTIONS:MCOMPAT9}
-RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:${PORTSDIR}/misc/compat9x
-.endif
-.if ${PORT_OPTIONS:MGCC46}
-RUN_DEPENDS+= ${LOCALBASE}/lib/gcc46/libstdc++.so.6:${PORTSDIR}/lang/gcc46
-.endif
-.if ${PORT_OPTIONS:MGCCXX}
-RUN_DEPENDS+= ${LOCALBASE}/lib/gcc46/libstdc++.so.6:${PORTSDIR}/lang/gcc
-.endif
+BUILD_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:${PORTSDIR}/misc/compat9x
.endif
post-extract:
${GUNZIP_CMD} ${WRKSRC}/share/man/man1/opera.1.gz
+do-build:
+.if ${OSVERSION} >= 1000054
+ ${CP} ${LOCALBASE}/lib/compat/libstdc++.so.6 ${WRKSRC}
+.endif
+
do-configure:
${MV} ${WRKSRC}/share/man ${WRKSRC}/man
- ${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
-e 's|share/man|man|g' ${WRKSRC}/install
- ${REINPLACE_CMD} -e 's|"$${0%/.}"|${PREFIX}|g' \
+ @${REINPLACE_CMD} -e 's|"$${0%/.}"|${PREFIX}|g' \
-e 's|/usr/local/profile|$$HOME/.opera|' \
${WRKSRC}/opera
- ${REINPLACE_CMD} -e 's|@@{PREFIX}|${PREFIX}|g' \
+ @${REINPLACE_CMD} -e 's|@@{PREFIX}|${PREFIX}|g' \
-e 's|@@{_SUFFIX}||g' -e 's|@@{SUFFIX}||g' \
-e 's|@@{USUFFIX}||g' \
${WRKSRC}/share/applications/opera-browser.desktop \
${WRKSRC}/share/mime/packages/opera-extension.xml \
${WRKSRC}/man/man1/opera.1
- ${REINPLACE_CMD} -e 's|/usr/X11R6/lib/browser_plugins|${WEBPLUGIN_SUBDIR}|g' \
+ @${REINPLACE_CMD} -e 's|/usr/X11R6/lib/browser_plugins|${WEBPLUGIN_SUBDIR}|g' \
${WRKSRC}/share/opera/defaults/pluginpath.ini
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/opera ${STAGEDIR}${PREFIX}/bin/
${TAR} -C ${WRKSRC} -cf - lib man share | ${TAR} -C ${STAGEDIR}${PREFIX} -xf -
- ${MKDIR} ${STAGEDIR}${PREFIX}/etc/libmap.d
+ ${INSTALL_LIB} ${WRKSRC}/libstdc++.so.6 ${STAGEDIR}${PREFIX}/lib/opera
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/libmap.d
${INSTALL_DATA} ${FILESDIR}/libmap.conf \
${STAGEDIR}${PREFIX}/etc/libmap.d/opera.conf
-# target to build distinfo for both arch
-makesum-all:
- make makesum FETCH_ALL=yes
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/opera/files/patch-opera b/www/opera/files/patch-opera
new file mode 100644
index 000000000000..21c0bb271f10
--- /dev/null
+++ b/www/opera/files/patch-opera
@@ -0,0 +1,7 @@
+Index: opera
+@@ -1,4 +1,5 @@
+ #!/bin/sh
+ export OPERA_DIR=${OPERA_DIR:-"${0%/*}"/share/opera}
+ export OPERA_PERSONALDIR=${OPERA_PERSONALDIR:-"${0%/*}"/profile}
++export LD_LIBRARY_PATH="${0%/*}"/lib/opera:$LD_LIBRARY_PATH
+ exec "${0%/*}"/lib/opera/opera "$@"
diff --git a/www/opera/pkg-descr b/www/opera/pkg-descr
index b33bdf73eac4..9006a63dfaf5 100644
--- a/www/opera/pkg-descr
+++ b/www/opera/pkg-descr
@@ -1,7 +1,7 @@
The most full-featured Internet power tool on the market, Opera includes
pop-up blocking, tabbed browsing, integrated searches, and advanced functions
like Opera's groundbreaking E-mail program, RSS Newsfeeds and IRC chat. And
-because we know that our users have different needs, you can customize
+because we know that our users have different needs, you can customize
the look and content of your Opera browser with a few clicks of the mouse.
WWW: http://www.opera.com/
diff --git a/www/opera/pkg-plist b/www/opera/pkg-plist
index 934998b8396e..50ad4d6ed336 100644
--- a/www/opera/pkg-plist
+++ b/www/opera/pkg-plist
@@ -4,6 +4,7 @@ lib/opera/gstreamer/plugins/libgstoperamatroska.so
lib/opera/gstreamer/plugins/libgstoperavp8.so
lib/opera/liboperagtk2.so
lib/opera/liboperakde4.so
+lib/opera/libstdc++.so.6
lib/opera/opera
lib/opera/plugins/README
lib/opera/pluginwrapper/operapluginwrapper
@@ -474,4 +475,3 @@ share/mime/packages/opera-extension.xml
@dirrm lib/opera/gstreamer/plugins
@dirrm lib/opera/gstreamer
@dirrm lib/opera
-@dirrmtry etc/libmap.d