aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache-AuthTicket
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-05-09 09:21:28 +0800
committeredwin <edwin@FreeBSD.org>2003-05-09 09:21:28 +0800
commit7070422323156d7b3f06171bc44758ea786fe1ff (patch)
treeef56b8ded261330dcba5f0f25abd1ec12aa40a1e /www/p5-Apache-AuthTicket
parent967abb004a55ef99a484e63e5beee2251ba83f16 (diff)
downloadfreebsd-ports-gnome-7070422323156d7b3f06171bc44758ea786fe1ff.tar.gz
freebsd-ports-gnome-7070422323156d7b3f06171bc44758ea786fe1ff.tar.zst
freebsd-ports-gnome-7070422323156d7b3f06171bc44758ea786fe1ff.zip
conditionalize dependencies on modules included in perl 5.8
Make dependencies on modules included in the perl 5.8 distribution conditional on the perl version installed. While I'm here, remove SITE_PERL and MAN(3)PREFIX. CVS: PR: ports/50589 Submitted by: Erwin Lansing <erwin@lansing.dk> ---------------------------------------------------------------------- CVS: Enter Log. Lines beginning with `CVS:' are removed automatically
Diffstat (limited to 'www/p5-Apache-AuthTicket')
-rw-r--r--www/p5-Apache-AuthTicket/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/www/p5-Apache-AuthTicket/Makefile b/www/p5-Apache-AuthTicket/Makefile
index 9d9dc9b0fcc8..659ff24b7d56 100644
--- a/www/p5-Apache-AuthTicket/Makefile
+++ b/www/p5-Apache-AuthTicket/Makefile
@@ -16,13 +16,18 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Perl modules that implement a cookie-based authentication system
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Apache/AuthCookie.pm:${PORTSDIR}/www/p5-Apache-AuthCookie \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Apache::AuthTicket.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.include <bsd.port.post.mk>