aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Blog-Spam
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-08-01 02:55:40 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-08-01 02:55:40 +0800
commit637b1d4d15cc0b217b9c50f4e82c2c1fee2cac74 (patch)
tree31f27ee5581999a10d9eacdef57aa020a7f956fc /www/p5-Blog-Spam
parentfed21603ac44402df71983e87934f91468cfe820 (diff)
downloadfreebsd-ports-gnome-637b1d4d15cc0b217b9c50f4e82c2c1fee2cac74.tar.gz
freebsd-ports-gnome-637b1d4d15cc0b217b9c50f4e82c2c1fee2cac74.tar.zst
freebsd-ports-gnome-637b1d4d15cc0b217b9c50f4e82c2c1fee2cac74.zip
- Add LICENSE
- Add BUILD_DEPENDS - Sort PLIST - Reformat pkg-descr - Use CPAN as primary WWW - Use single space after WWW:
Diffstat (limited to 'www/p5-Blog-Spam')
-rw-r--r--www/p5-Blog-Spam/Makefile8
-rw-r--r--www/p5-Blog-Spam/pkg-descr12
-rw-r--r--www/p5-Blog-Spam/pkg-plist60
3 files changed, 42 insertions, 38 deletions
diff --git a/www/p5-Blog-Spam/Makefile b/www/p5-Blog-Spam/Makefile
index 5139aa510bae..75382a96013b 100644
--- a/www/p5-Blog-Spam/Makefile
+++ b/www/p5-Blog-Spam/Makefile
@@ -11,13 +11,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Blog & Forum SPAM Detection
-RUN_DEPENDS= p5-Net-CIDR-Lite>=0:${PORTSDIR}/net/p5-Net-CIDR-Lite \
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Net-CIDR-Lite>=0:${PORTSDIR}/net/p5-Net-CIDR-Lite \
p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
p5-RPC-XML>=0:${PORTSDIR}/net/p5-RPC-XML \
p5-URI-Find>=0:${PORTSDIR}/textproc/p5-URI-Find \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
USE_PERL5= configure
+USES= perl5
.include <bsd.port.mk>
diff --git a/www/p5-Blog-Spam/pkg-descr b/www/p5-Blog-Spam/pkg-descr
index 193b79cd8e71..327830076eac 100644
--- a/www/p5-Blog-Spam/pkg-descr
+++ b/www/p5-Blog-Spam/pkg-descr
@@ -1,8 +1,8 @@
-The blogspam site exists to provide a service which allows you to
-test whether a submitted blog/forum comment is SPAM or not, in real-time.
+The blogspam site exists to provide a service which allows you to test whether a
+submitted blog/forum comment is SPAM or not, in real-time.
-We can identify many common SPAM characteristics and using them allow
-comments to be blocked - cutting down on the SPAM that might otherwise
-affect your site.
+We can identify many common SPAM characteristics and using them allow comments
+to be blocked - cutting down on the SPAM that might otherwise affect your site.
-WWW: http://blogspam.net/
+WWW: http://search.cpan.org/dist/Blog-Spam/
+WWW: http://blogspam.net/
diff --git a/www/p5-Blog-Spam/pkg-plist b/www/p5-Blog-Spam/pkg-plist
index 125f4faf82e2..8923b036034c 100644
--- a/www/p5-Blog-Spam/pkg-plist
+++ b/www/p5-Blog-Spam/pkg-plist
@@ -1,3 +1,29 @@
+bin/blogspam
+%%SITE_PERL%%/Blog/Spam/API.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/00blacklist.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/00whitelist.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/Sample.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/badip.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/bayesian.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/bogusip.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/drone.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/dropme.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/emailtests.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/hashcash.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/httpbl.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/logger.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/lotsaurls.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/multilinks.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/rdns.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/requiremx.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/sfs.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/size.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/stopwords.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/strong.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/surbl.pm
+%%SITE_PERL%%/Blog/Spam/Plugin/wordcount.pm
+%%SITE_PERL%%/Blog/Spam/Server.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Blog/Spam/.packlist
%%PERL5_MAN3%%/Blog::Spam::API.3.gz
%%PERL5_MAN3%%/Blog::Spam::Plugin::00blacklist.3.gz
%%PERL5_MAN3%%/Blog::Spam::Plugin::00whitelist.3.gz
@@ -23,34 +49,8 @@
%%PERL5_MAN3%%/Blog::Spam::Plugin::wordcount.3.gz
%%PERL5_MAN3%%/Blog::Spam::Server.3.gz
man/man1/blogspam.1.gz
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Blog/Spam/.packlist
-%%SITE_PERL%%/Blog/Spam/API.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/00blacklist.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/00whitelist.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/Sample.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/badip.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/bayesian.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/bogusip.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/drone.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/dropme.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/emailtests.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/hashcash.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/httpbl.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/logger.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/lotsaurls.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/multilinks.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/rdns.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/requiremx.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/sfs.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/size.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/stopwords.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/strong.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/surbl.pm
-%%SITE_PERL%%/Blog/Spam/Plugin/wordcount.pm
-%%SITE_PERL%%/Blog/Spam/Server.pm
-bin/blogspam
-@dirrmtry %%SITE_PERL%%/Blog/Spam/Plugin
-@dirrmtry %%SITE_PERL%%/Blog/Spam
-@dirrmtry %%SITE_PERL%%/Blog
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Blog/Spam
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Blog/Spam
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Blog
+@dirrm %%SITE_PERL%%/Blog/Spam/Plugin
+@dirrm %%SITE_PERL%%/Blog/Spam
+@dirrmtry %%SITE_PERL%%/Blog