aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Gungho
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-10-14 22:59:17 +0800
committerclsung <clsung@FreeBSD.org>2007-10-14 22:59:17 +0800
commit16da4f78458e7adc036274c177d71bdfe4155ad0 (patch)
tree45913090aa9876644972ddd82fb73d3c45765484 /www/p5-Gungho
parent7e2d710cfadd141e6c925781b445933d0f258cb8 (diff)
downloadfreebsd-ports-gnome-16da4f78458e7adc036274c177d71bdfe4155ad0.tar.gz
freebsd-ports-gnome-16da4f78458e7adc036274c177d71bdfe4155ad0.tar.zst
freebsd-ports-gnome-16da4f78458e7adc036274c177d71bdfe4155ad0.zip
Gungho is Yet Another Web Crawler Framework, aimed to be extensible
and fast. Gungho tries to build from clean structures, based upon principles from the likes of Catalyst and Plagger, so that you can easily extend it to your liking. Features such as robot rules handling (robots.txt) and request throttling can be removed/added on the fly, just by specifying the components that you want to load. You can easily create additional functionality by writing your own component. WWW: http://search.cpan.org/dist/Gungho/
Diffstat (limited to 'www/p5-Gungho')
-rw-r--r--www/p5-Gungho/Makefile68
-rw-r--r--www/p5-Gungho/distinfo3
-rw-r--r--www/p5-Gungho/pkg-descr13
-rw-r--r--www/p5-Gungho/pkg-plist55
4 files changed, 139 insertions, 0 deletions
diff --git a/www/p5-Gungho/Makefile b/www/p5-Gungho/Makefile
new file mode 100644
index 000000000000..6ac71c0ff2d5
--- /dev/null
+++ b/www/p5-Gungho/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: p5-Gungho
+# Date created: 2006-07-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Gungho
+PORTVERSION= 0.08.013
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/D/DM/DMAKI
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Event Based High Performance Web Crawler Framework
+
+RUN_DEPENDS= ${SITE_PERL}/Best.pm:${PORTSDIR}/devel/p5-Best \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Class/C3.pm:${PORTSDIR}/devel/p5-Class-C3 \
+ ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector \
+ ${SITE_PERL}/Config/Any.pm:${PORTSDIR}/devel/p5-Config-Any \
+ ${SITE_PERL}/Data/Dump.pm:${PORTSDIR}/devel/p5-Data-Dump \
+ ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
+ ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class \
+ ${SITE_PERL}/Regexp/Common.pm:${PORTSDIR}/textproc/p5-Regexp-Common \
+ ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
+ ${SITE_PERL}/UNIVERSAL/isa.pm:${PORTSDIR}/devel/p5-UNIVERSAL-isa \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Gungho.3 Gungho::Base.3 Gungho::Component.3 \
+ Gungho::Component::Authentication.3 \
+ Gungho::Component::Authentication::Basic.3 \
+ Gungho::Component::Cache.3 \
+ Gungho::Component::RobotRules.3 \
+ Gungho::Component::RobotRules::Rule.3 \
+ Gungho::Component::RobotRules::Storage.3 \
+ Gungho::Component::RobotRules::Storage::Cache.3 \
+ Gungho::Component::RobotRules::Storage::DB_File.3 \
+ Gungho::Component::Throttle.3 \
+ Gungho::Component::Throttle::Domain.3 \
+ Gungho::Component::Throttle::Simple.3 \
+ Gungho::Component::Throttle::Throttler.3 \
+ Gungho::Engine.3 Gungho::Engine::Danga::Socket.3 \
+ Gungho::Engine::IO::Async.3 Gungho::Engine::POE.3 \
+ Gungho::Exception.3 Gungho::Handler.3 \
+ Gungho::Handler::FileWriter::Simple.3 \
+ Gungho::Handler::Null.3 \
+ Gungho::Inline.3 Gungho::Log.3 \
+ Gungho::Log::Dispatch.3 \
+ Gungho::Log::Simple.3 \
+ Gungho::Plugin.3 Gungho::Plugin::RequestLog.3 \
+ Gungho::Plugin::RequestTimer.3 \
+ Gungho::Provider.3 \
+ Gungho::Provider::File::Simple.3 \
+ Gungho::Provider::Simple.3 \
+ Gungho::Provider::YAML.3 \
+ Gungho::Request.3 Gungho::Request::http.3
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/script/gungho ${PREFIX}/bin/gungho
+
+.include <bsd.port.mk>
diff --git a/www/p5-Gungho/distinfo b/www/p5-Gungho/distinfo
new file mode 100644
index 000000000000..7765686cc652
--- /dev/null
+++ b/www/p5-Gungho/distinfo
@@ -0,0 +1,3 @@
+MD5 (Gungho-0.08013.tar.gz) = 2422cce7e51806a14f4ddf7e24fd9680
+SHA256 (Gungho-0.08013.tar.gz) = 8f64834793a5de6e4af08eb6194660b1f37f1bcd7a75046a3d0e66eee9831114
+SIZE (Gungho-0.08013.tar.gz) = 53746
diff --git a/www/p5-Gungho/pkg-descr b/www/p5-Gungho/pkg-descr
new file mode 100644
index 000000000000..abdee588954b
--- /dev/null
+++ b/www/p5-Gungho/pkg-descr
@@ -0,0 +1,13 @@
+Gungho is Yet Another Web Crawler Framework, aimed to be extensible
+and fast.
+
+Gungho tries to build from clean structures, based upon principles
+from the likes of Catalyst and Plagger, so that you can easily
+extend it to your liking.
+
+Features such as robot rules handling (robots.txt) and request
+throttling can be removed/added on the fly, just by specifying
+the components that you want to load. You can easily create
+additional functionality by writing your own component.
+
+WWW: http://search.cpan.org/dist/Gungho/
diff --git a/www/p5-Gungho/pkg-plist b/www/p5-Gungho/pkg-plist
new file mode 100644
index 000000000000..f88ffd31d48d
--- /dev/null
+++ b/www/p5-Gungho/pkg-plist
@@ -0,0 +1,55 @@
+bin/gungho
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Gungho/.packlist
+%%SITE_PERL%%/Gungho.pm
+%%SITE_PERL%%/Gungho/Base.pm
+%%SITE_PERL%%/Gungho/Component.pm
+%%SITE_PERL%%/Gungho/Component/Authentication.pm
+%%SITE_PERL%%/Gungho/Component/Authentication/Basic.pm
+%%SITE_PERL%%/Gungho/Component/Cache.pm
+%%SITE_PERL%%/Gungho/Component/RobotRules.pm
+%%SITE_PERL%%/Gungho/Component/RobotRules/Rule.pm
+%%SITE_PERL%%/Gungho/Component/RobotRules/Storage.pm
+%%SITE_PERL%%/Gungho/Component/RobotRules/Storage/Cache.pm
+%%SITE_PERL%%/Gungho/Component/RobotRules/Storage/DB_File.pm
+%%SITE_PERL%%/Gungho/Component/Throttle.pm
+%%SITE_PERL%%/Gungho/Component/Throttle/Domain.pm
+%%SITE_PERL%%/Gungho/Component/Throttle/Simple.pm
+%%SITE_PERL%%/Gungho/Component/Throttle/Throttler.pm
+%%SITE_PERL%%/Gungho/Engine.pm
+%%SITE_PERL%%/Gungho/Engine/Danga/Socket.pm
+%%SITE_PERL%%/Gungho/Engine/IO/Async.pm
+%%SITE_PERL%%/Gungho/Engine/POE.pm
+%%SITE_PERL%%/Gungho/Exception.pm
+%%SITE_PERL%%/Gungho/Handler.pm
+%%SITE_PERL%%/Gungho/Handler/FileWriter/Simple.pm
+%%SITE_PERL%%/Gungho/Handler/Null.pm
+%%SITE_PERL%%/Gungho/Inline.pm
+%%SITE_PERL%%/Gungho/Log.pm
+%%SITE_PERL%%/Gungho/Log/Dispatch.pm
+%%SITE_PERL%%/Gungho/Log/Simple.pm
+%%SITE_PERL%%/Gungho/Plugin.pm
+%%SITE_PERL%%/Gungho/Plugin/RequestLog.pm
+%%SITE_PERL%%/Gungho/Plugin/RequestTimer.pm
+%%SITE_PERL%%/Gungho/Provider.pm
+%%SITE_PERL%%/Gungho/Provider/File/Simple.pm
+%%SITE_PERL%%/Gungho/Provider/Simple.pm
+%%SITE_PERL%%/Gungho/Provider/YAML.pm
+%%SITE_PERL%%/Gungho/Request.pm
+%%SITE_PERL%%/Gungho/Request/http.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gungho
+@dirrmtry %%SITE_PERL%%/Gungho/Request
+@dirrmtry %%SITE_PERL%%/Gungho/Provider/File
+@dirrmtry %%SITE_PERL%%/Gungho/Provider
+@dirrmtry %%SITE_PERL%%/Gungho/Plugin
+@dirrmtry %%SITE_PERL%%/Gungho/Log
+@dirrmtry %%SITE_PERL%%/Gungho/Handler/FileWriter
+@dirrmtry %%SITE_PERL%%/Gungho/Handler
+@dirrmtry %%SITE_PERL%%/Gungho/Engine/IO
+@dirrmtry %%SITE_PERL%%/Gungho/Engine/Danga
+@dirrmtry %%SITE_PERL%%/Gungho/Engine
+@dirrmtry %%SITE_PERL%%/Gungho/Component/Throttle
+@dirrmtry %%SITE_PERL%%/Gungho/Component/RobotRules/Storage
+@dirrmtry %%SITE_PERL%%/Gungho/Component/RobotRules
+@dirrmtry %%SITE_PERL%%/Gungho/Component/Authentication
+@dirrmtry %%SITE_PERL%%/Gungho/Component
+@dirrmtry %%SITE_PERL%%/Gungho