aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTML-Display
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-10-24 18:33:31 +0800
committerrafan <rafan@FreeBSD.org>2007-10-24 18:33:31 +0800
commitef086447bad79369e4e612ec50b4cffb1610dcb1 (patch)
tree8721f4f89a04c70096ec06763ae16991674eb684 /www/p5-HTML-Display
parentae400a6d01ac387438f62ade6ea422300d962a3b (diff)
downloadfreebsd-ports-gnome-ef086447bad79369e4e612ec50b4cffb1610dcb1.tar.gz
freebsd-ports-gnome-ef086447bad79369e4e612ec50b4cffb1610dcb1.tar.zst
freebsd-ports-gnome-ef086447bad79369e4e612ec50b4cffb1610dcb1.zip
This module abstracts the task of displaying HTML to the user. The
displaying is done by launching a browser and navigating it to either a temporary file with the HTML stored in it, or, if possible, by pushing the HTML directly into the browser window. WWW: http://search.cpan.org/dist/HTML-Display/
Diffstat (limited to 'www/p5-HTML-Display')
-rw-r--r--www/p5-HTML-Display/Makefile41
-rw-r--r--www/p5-HTML-Display/distinfo3
-rw-r--r--www/p5-HTML-Display/pkg-descr6
-rw-r--r--www/p5-HTML-Display/pkg-plist19
4 files changed, 69 insertions, 0 deletions
diff --git a/www/p5-HTML-Display/Makefile b/www/p5-HTML-Display/Makefile
new file mode 100644
index 000000000000..d252f288f3cf
--- /dev/null
+++ b/www/p5-HTML-Display/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: p5-HTML-Display
+# Date created: 24 Oct 2007
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Display
+PORTVERSION= 0.39
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= Display HTML locally in a browser
+
+RUN_DEPENDS= p5-HTML-TokeParser-Simple>=2:${PORTSDIR}/www/p5-HTML-TokeParser-Simple \
+ p5-libwww>=5.69:${PORTSDIR}/www/p5-libwww \
+ p5-parent>=0.218:${PORTSDIR}/devel/p5-parent \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS:= ${RUN_DEPENDS} \
+ p5-Test-Harness>=2.30:${PORTSDIR}/devel/p5-Test-Harness
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Display.3 \
+ HTML::Display::Common.3 \
+ HTML::Display::Debian.3 \
+ HTML::Display::Dump.3 \
+ HTML::Display::Galeon.3 \
+ HTML::Display::Mozilla.3 \
+ HTML::Display::OSX.3 \
+ HTML::Display::Opera.3 \
+ HTML::Display::Phoenix.3 \
+ HTML::Display::TempFile.3 \
+ HTML::Display::Win32.3 \
+ HTML::Display::Win32::IE.3 \
+ HTML::Display::Win32::OLE.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Display/distinfo b/www/p5-HTML-Display/distinfo
new file mode 100644
index 000000000000..0237a32aef32
--- /dev/null
+++ b/www/p5-HTML-Display/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-Display-0.39.tar.gz) = ca1fd7653d11ed7be7a03f2f5126509b
+SHA256 (HTML-Display-0.39.tar.gz) = d54bba31e43e698506bfd8d3f33032043c0b36113e21f702c11404055cf76b09
+SIZE (HTML-Display-0.39.tar.gz) = 13720
diff --git a/www/p5-HTML-Display/pkg-descr b/www/p5-HTML-Display/pkg-descr
new file mode 100644
index 000000000000..e3fe2525ee68
--- /dev/null
+++ b/www/p5-HTML-Display/pkg-descr
@@ -0,0 +1,6 @@
+This module abstracts the task of displaying HTML to the user. The
+displaying is done by launching a browser and navigating it to either
+a temporary file with the HTML stored in it, or, if possible, by
+pushing the HTML directly into the browser window.
+
+WWW: http://search.cpan.org/dist/HTML-Display/
diff --git a/www/p5-HTML-Display/pkg-plist b/www/p5-HTML-Display/pkg-plist
new file mode 100644
index 000000000000..de882bdb94f1
--- /dev/null
+++ b/www/p5-HTML-Display/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Display/.packlist
+%%SITE_PERL%%/HTML/Display.pm
+%%SITE_PERL%%/HTML/Display/Common.pm
+%%SITE_PERL%%/HTML/Display/Debian.pm
+%%SITE_PERL%%/HTML/Display/Dump.pm
+%%SITE_PERL%%/HTML/Display/Galeon.pm
+%%SITE_PERL%%/HTML/Display/Mozilla.pm
+%%SITE_PERL%%/HTML/Display/OSX.pm
+%%SITE_PERL%%/HTML/Display/Opera.pm
+%%SITE_PERL%%/HTML/Display/Phoenix.pm
+%%SITE_PERL%%/HTML/Display/TempFile.pm
+%%SITE_PERL%%/HTML/Display/Win32.pm
+%%SITE_PERL%%/HTML/Display/Win32/IE.pm
+%%SITE_PERL%%/HTML/Display/Win32/OLE.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Display
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML/Display/Win32
+@dirrmtry %%SITE_PERL%%/HTML/Display
+@dirrmtry %%SITE_PERL%%/HTML