aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTML-Template-Expr
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2001-12-03 09:12:56 +0800
committerkuriyama <kuriyama@FreeBSD.org>2001-12-03 09:12:56 +0800
commit69332e22053b4d36414ffa12e3f962d01979b592 (patch)
tree337eb7547ee69c00401ecd1da716c68b49d63ca4 /www/p5-HTML-Template-Expr
parentfe363d8b61607c0826d56046d9ebe31a50ca6fd5 (diff)
downloadfreebsd-ports-gnome-69332e22053b4d36414ffa12e3f962d01979b592.tar.gz
freebsd-ports-gnome-69332e22053b4d36414ffa12e3f962d01979b592.tar.zst
freebsd-ports-gnome-69332e22053b4d36414ffa12e3f962d01979b592.zip
Add p5-HTML-Template-Expr 0.03,
perl module to use HTML Templates which allows expressions. PR: ports/32348 Submitted by: nork@cityfujisawa.ne.jp
Diffstat (limited to 'www/p5-HTML-Template-Expr')
-rw-r--r--www/p5-HTML-Template-Expr/Makefile27
-rw-r--r--www/p5-HTML-Template-Expr/distinfo1
-rw-r--r--www/p5-HTML-Template-Expr/pkg-comment1
-rw-r--r--www/p5-HTML-Template-Expr/pkg-descr10
-rw-r--r--www/p5-HTML-Template-Expr/pkg-plist7
5 files changed, 46 insertions, 0 deletions
diff --git a/www/p5-HTML-Template-Expr/Makefile b/www/p5-HTML-Template-Expr/Makefile
new file mode 100644
index 000000000000..bb6cd83c2802
--- /dev/null
+++ b/www/p5-HTML-Template-Expr/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-HTML-Template-Expr
+# Date Created: 2001/11/28
+# Whom: nork@cityfujisawa.ne.jp
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Template-Expr
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nork@cityfujisawa.ne.jp
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Template::Expr.3
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Template-Expr/distinfo b/www/p5-HTML-Template-Expr/distinfo
new file mode 100644
index 000000000000..6c73ab472b4a
--- /dev/null
+++ b/www/p5-HTML-Template-Expr/distinfo
@@ -0,0 +1 @@
+MD5 (HTML-Template-Expr-0.03.tar.gz) = ea0b9412a903f995016c5d451466969f
diff --git a/www/p5-HTML-Template-Expr/pkg-comment b/www/p5-HTML-Template-Expr/pkg-comment
new file mode 100644
index 000000000000..7e49dbc95e05
--- /dev/null
+++ b/www/p5-HTML-Template-Expr/pkg-comment
@@ -0,0 +1 @@
+Perl module to use HTML Templates which allows expressions
diff --git a/www/p5-HTML-Template-Expr/pkg-descr b/www/p5-HTML-Template-Expr/pkg-descr
new file mode 100644
index 000000000000..c348b54edea6
--- /dev/null
+++ b/www/p5-HTML-Template-Expr/pkg-descr
@@ -0,0 +1,10 @@
+This module provides an extension to HTML::Template which allows
+expressions in the template syntax. This is purely an addition - all
+the normal HTML::Template options, syntax and behaviors will still
+work. See HTML::Template for details.
+
+Expression support includes comparisons, math operations, string
+operations and a mechanism to allow you add your own functions at
+runtime.
+
+WWW: http://sourceforge.net/projects/html-template/
diff --git a/www/p5-HTML-Template-Expr/pkg-plist b/www/p5-HTML-Template-Expr/pkg-plist
new file mode 100644
index 000000000000..00c25e615d3b
--- /dev/null
+++ b/www/p5-HTML-Template-Expr/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/HTML/Template/Expr.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/Template/Expr/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/HTML/Template 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/HTML 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/Template/Expr
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/Template 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true