aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTML-Template-Pluggable
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-05-15 04:19:39 +0800
committersat <sat@FreeBSD.org>2006-05-15 04:19:39 +0800
commit3443a284cd0fe2dd03b79f4b9042a57bc6838695 (patch)
treebd394be6a8bbafa8c5a79e6b50e9fc6be2f2dd6d /www/p5-HTML-Template-Pluggable
parentddde4c736f51b43e2ecef16884e9e1128bf80abd (diff)
downloadfreebsd-ports-gnome-3443a284cd0fe2dd03b79f4b9042a57bc6838695.tar.gz
freebsd-ports-gnome-3443a284cd0fe2dd03b79f4b9042a57bc6838695.tar.zst
freebsd-ports-gnome-3443a284cd0fe2dd03b79f4b9042a57bc6838695.zip
Add p5-HTML-Template-Pluggable: Extends HTML::Template with plugin support
PR: ports/94444 (based on) Submitted by: Espen Tagestad <espen@modula.no> Approved by: krion (mentor)
Diffstat (limited to 'www/p5-HTML-Template-Pluggable')
-rw-r--r--www/p5-HTML-Template-Pluggable/Makefile35
-rw-r--r--www/p5-HTML-Template-Pluggable/distinfo3
-rw-r--r--www/p5-HTML-Template-Pluggable/pkg-descr12
-rw-r--r--www/p5-HTML-Template-Pluggable/pkg-plist5
4 files changed, 55 insertions, 0 deletions
diff --git a/www/p5-HTML-Template-Pluggable/Makefile b/www/p5-HTML-Template-Pluggable/Makefile
new file mode 100644
index 000000000000..83ab06c753f2
--- /dev/null
+++ b/www/p5-HTML-Template-Pluggable/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: HTML::Template::Pluggable
+# Date created: 21 March 2006
+# Whom: Espen Tagestad <espen@tagestad.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Template-Pluggable
+PORTVERSION= 0.15
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= espen@tagestad.no
+COMMENT= Extends HTML::Template with plugin support
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
+ ${SITE_PERL}/Test/MockObject.pm:${PORTSDIR}/devel/p5-Test-MockObject \
+ ${SITE_PERL}/Regexp/Common.pm:${PORTSDIR}/textproc/p5-Regexp-Common \
+ ${SITE_PERL}/Class/Trigger.pm:${PORTSDIR}/devel/p5-Class-Trigger
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Template::Pluggable.3 \
+ HTML::Template::Plugin::Dot.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500806
+IGNORE= needs Perl 5.8.6 or above (lang/perl5.8)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTML-Template-Pluggable/distinfo b/www/p5-HTML-Template-Pluggable/distinfo
new file mode 100644
index 000000000000..bccd9d0e41bb
--- /dev/null
+++ b/www/p5-HTML-Template-Pluggable/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-Template-Pluggable-0.15.tar.gz) = 47df73c8a75e1d3a608ef1ee97642d32
+SHA256 (HTML-Template-Pluggable-0.15.tar.gz) = 93e432cb9fd1596c5d2d89e64d94a32c966bcab97c306c1d0291eb9a0f97aa26
+SIZE (HTML-Template-Pluggable-0.15.tar.gz) = 25269
diff --git a/www/p5-HTML-Template-Pluggable/pkg-descr b/www/p5-HTML-Template-Pluggable/pkg-descr
new file mode 100644
index 000000000000..1ad0e85e715b
--- /dev/null
+++ b/www/p5-HTML-Template-Pluggable/pkg-descr
@@ -0,0 +1,12 @@
+Just use this module instead of HTML::Template, then use any plugins, and go on
+with life.
+
+By adding support for the module included, HTML::Template::Plugin::Dot, to
+HTML::Template, the programmers' job of sending data to the template is easier,
+and designers have easier access to more data to display in the template,
+without learning any more tag syntax.
+
+WWW: http://search.cpan.org/dist/HTML-Template-Pluggable
+
+-- Espen Tagestad
+espen@tagestad.no
diff --git a/www/p5-HTML-Template-Pluggable/pkg-plist b/www/p5-HTML-Template-Pluggable/pkg-plist
new file mode 100644
index 000000000000..349e0c30619e
--- /dev/null
+++ b/www/p5-HTML-Template-Pluggable/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/HTML/Template/Pluggable.pm
+%%SITE_PERL%%/HTML/Template/Plugin/Dot.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/Pluggable/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/Pluggable
+@dirrmtry %%SITE_PERL%%/HTML/Template/Plugin