aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTTP-GHTTP/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2001-02-11 14:50:52 +0800
committervanilla <vanilla@FreeBSD.org>2001-02-11 14:50:52 +0800
commit442f83a43b3623995a45e141451709d8a7ff140a (patch)
treebcfeaf22419dbebe778873e9abb549426421ab6b /www/p5-HTTP-GHTTP/Makefile
parent6a008f38a5a6b0d57dab31d1f657ca9286259b15 (diff)
downloadfreebsd-ports-gnome-442f83a43b3623995a45e141451709d8a7ff140a.tar.gz
freebsd-ports-gnome-442f83a43b3623995a45e141451709d8a7ff140a.tar.zst
freebsd-ports-gnome-442f83a43b3623995a45e141451709d8a7ff140a.zip
New port: HTTP::GHTTP - Perl interface to the gnome ghttp library
PR: ports/24246 Submitted by: Sergey Skvortsov <skv@protey.ru>
Diffstat (limited to 'www/p5-HTTP-GHTTP/Makefile')
-rw-r--r--www/p5-HTTP-GHTTP/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/www/p5-HTTP-GHTTP/Makefile b/www/p5-HTTP-GHTTP/Makefile
new file mode 100644
index 000000000000..b82216102343
--- /dev/null
+++ b/www/p5-HTTP-GHTTP/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: HTTP::GHTTP
+# Date created: 11 Jan 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-GHTTP
+PORTVERSION= 1.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+LIB_DEPENDS= ghttp.1:${PORTSDIR}/www/libghttp
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= LIBS="-L${LOCALBASE}/lib" INC="-I${LOCALBASE}/include"
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= HTTP::GHTTP.3
+
+.include <bsd.port.mk>