aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-LWPx-ParanoidAgent
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-12-19 20:02:39 +0800
committerclsung <clsung@FreeBSD.org>2006-12-19 20:02:39 +0800
commit0f2cfa6d1de235deeb5a03d10f5e57a6f7b89bca (patch)
tree47e6ce940a8cc8df625329f16371d4898ff6e65f /www/p5-LWPx-ParanoidAgent
parenta663fadd165dba45bd04e4123dba5e2658eb5cad (diff)
downloadfreebsd-ports-gnome-0f2cfa6d1de235deeb5a03d10f5e57a6f7b89bca.tar.gz
freebsd-ports-gnome-0f2cfa6d1de235deeb5a03d10f5e57a6f7b89bca.tar.zst
freebsd-ports-gnome-0f2cfa6d1de235deeb5a03d10f5e57a6f7b89bca.zip
LWPx::ParanoidAgent is a class subclassing LWP::UserAgent, but
paranoid against attackers. It's to be used when you're fetching a remote resource on behalf of a possibly malicious user. WWW: http://search.cpan.org/dist/LWPx-ParanoidAgent/
Diffstat (limited to 'www/p5-LWPx-ParanoidAgent')
-rw-r--r--www/p5-LWPx-ParanoidAgent/Makefile36
-rw-r--r--www/p5-LWPx-ParanoidAgent/distinfo3
-rw-r--r--www/p5-LWPx-ParanoidAgent/pkg-descr22
-rw-r--r--www/p5-LWPx-ParanoidAgent/pkg-plist8
4 files changed, 69 insertions, 0 deletions
diff --git a/www/p5-LWPx-ParanoidAgent/Makefile b/www/p5-LWPx-ParanoidAgent/Makefile
new file mode 100644
index 000000000000..7b81479c915e
--- /dev/null
+++ b/www/p5-LWPx-ParanoidAgent/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-LWPx-ParanoidAgent
+# Date created: Tue Dec 19 17:00:41 CST 2006
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LWPx-ParanoidAgent
+PORTVERSION= 1.03
+CATEGORIES= www security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= LWPx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Subclass of LWP::UserAgent that protects you from harm
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= LWPx::ParanoidAgent.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.if ${PERL_LEVEL} < 500703
+BUILD_DEPENDS+= ${SITE_PERL}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-LWPx-ParanoidAgent/distinfo b/www/p5-LWPx-ParanoidAgent/distinfo
new file mode 100644
index 000000000000..e4ca71bfb7b6
--- /dev/null
+++ b/www/p5-LWPx-ParanoidAgent/distinfo
@@ -0,0 +1,3 @@
+MD5 (LWPx-ParanoidAgent-1.03.tar.gz) = 7b5e79ccc33968401085f576d5c2fffe
+SHA256 (LWPx-ParanoidAgent-1.03.tar.gz) = abab342ed3f01d0eb906e6cb067e87d7672a2fb2afd871dacb6397f8e601af03
+SIZE (LWPx-ParanoidAgent-1.03.tar.gz) = 13024
diff --git a/www/p5-LWPx-ParanoidAgent/pkg-descr b/www/p5-LWPx-ParanoidAgent/pkg-descr
new file mode 100644
index 000000000000..e9799e75147e
--- /dev/null
+++ b/www/p5-LWPx-ParanoidAgent/pkg-descr
@@ -0,0 +1,22 @@
+LWPx::ParanoidAgent is a class subclassing LWP::UserAgent, but
+paranoid against attackers. It's to be used when you're fetching
+a remote resource on behalf of a possibly malicious user.
+
+This class can do whatever LWP::UserAgent can (callbacks, uploads
+from files, etc), except proxy support is explicitly removed, because
+in that case you should do your paranoia at your proxy.
+
+Also, the schemes are limited to http and https, which are mapped to
+LWPx::Protocol::http_paranoid and LWPx::Protocol::https_paranoid,
+respectively, which are forked versions of the same ones without
+the "_paranoid". Subclassing them didn't look possible, as they were
+essentially just one huge function.
+
+This class protects you from connecting to internal IP ranges
+(unless you whitelist them), hostnames/IPs that you blacklist, remote
+webserver tarpitting your process (the timeout parameter is changed to
+be a global timeout over the entire process), and all combinations of
+redirects and DNS tricks to otherwise tarpit and/or connect to internal
+resources.
+
+WWW: http://search.cpan.org/dist/LWPx-ParanoidAgent/
diff --git a/www/p5-LWPx-ParanoidAgent/pkg-plist b/www/p5-LWPx-ParanoidAgent/pkg-plist
new file mode 100644
index 000000000000..7e3f081e144b
--- /dev/null
+++ b/www/p5-LWPx-ParanoidAgent/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/LWPx/ParanoidAgent.pm
+%%SITE_PERL%%/LWPx/Protocol/http_paranoid.pm
+%%SITE_PERL%%/LWPx/Protocol/https_paranoid.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/LWPx/ParanoidAgent/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWPx/ParanoidAgent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWPx
+@dirrmtry %%SITE_PERL%%/LWPx/Protocol
+@dirrmtry %%SITE_PERL%%/LWPx