aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-RTx-Calendar
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /www/p5-RTx-Calendar
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'www/p5-RTx-Calendar')
-rw-r--r--www/p5-RTx-Calendar/Makefile5
-rw-r--r--www/p5-RTx-Calendar/pkg-plist27
2 files changed, 5 insertions, 27 deletions
diff --git a/www/p5-RTx-Calendar/Makefile b/www/p5-RTx-Calendar/Makefile
index 946f6295885b..0350318e2184 100644
--- a/www/p5-RTx-Calendar/Makefile
+++ b/www/p5-RTx-Calendar/Makefile
@@ -3,6 +3,7 @@
PORTNAME= RTx-Calendar
PORTVERSION= 0.20
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -60,4 +61,8 @@ do-configure:
${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ./${CONFIGURE_SCRIPT} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
+post-install:
+ ${RM} ${STAGEDIR}${PREFIX}/man/auto/RTx/Calendar/.packlist
+ ${RMDIR} -p ${STAGEDIR}${PREFIX}/man/auto/RTx/Calendar 2>/dev/null || :
+
.include <bsd.port.mk>
diff --git a/www/p5-RTx-Calendar/pkg-plist b/www/p5-RTx-Calendar/pkg-plist
index bf52d589b1af..a28c52aa1289 100644
--- a/www/p5-RTx-Calendar/pkg-plist
+++ b/www/p5-RTx-Calendar/pkg-plist
@@ -1,4 +1,3 @@
-man/auto/RTx/Calendar/.packlist.gz
man/man3/RTx::Calendar.3.gz
%%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Elements/Tabs/Privileged
%%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Ticket/Elements/Tabs/Default
@@ -20,29 +19,3 @@ man/man3/RTx::Calendar.3.gz
%%RTHOME%%/plugins/RTx-Calendar/static/images/starts.png
%%RTHOME%%/plugins/RTx-Calendar/static/images/starts_due.png
%%RTHOME%%/plugins/RTx-Calendar/static/images/updated.png
-@dirrmtry man/auto/RTx/Calendar
-@dirrmtry man/auto/RTx
-@dirrmtry man/auto
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Elements/Tabs
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Elements
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Ticket/Elements/Tabs
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Ticket/Elements
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/Ticket
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/User/Elements/Tabs
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/User/Elements
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar/User
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks/RTx-Calendar
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Callbacks
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Elements
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/NoAuth/Calendar
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/NoAuth
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Prefs/Elements
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Prefs
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html/Search
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/html
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/lib/RTx
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/lib
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/static/css
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/static/images
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar/static
-@dirrmtry %%RTHOME%%/plugins/RTx-Calendar