aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-WWW-SourceForge
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2005-01-26 16:17:02 +0800
committerijliao <ijliao@FreeBSD.org>2005-01-26 16:17:02 +0800
commit0b39b99981d59e05b3ba0c617eb2960c89d3a01e (patch)
tree41f84c68c0b7aa01cbd17902841e4c61ae6c1286 /www/p5-WWW-SourceForge
parent5ab13acef692d6e19299771d13db127412b3f145 (diff)
downloadfreebsd-ports-gnome-0b39b99981d59e05b3ba0c617eb2960c89d3a01e.tar.gz
freebsd-ports-gnome-0b39b99981d59e05b3ba0c617eb2960c89d3a01e.tar.zst
freebsd-ports-gnome-0b39b99981d59e05b3ba0c617eb2960c89d3a01e.zip
add p5-WWW-SourceForge 0.083
Retrieve infromation from SourceForge site PR: 72988 Submitted by: Yuan-Chung Hsiao <ychsiao@ychsiao.idv.tw>
Diffstat (limited to 'www/p5-WWW-SourceForge')
-rw-r--r--www/p5-WWW-SourceForge/Makefile27
-rw-r--r--www/p5-WWW-SourceForge/distinfo2
-rw-r--r--www/p5-WWW-SourceForge/pkg-descr9
-rw-r--r--www/p5-WWW-SourceForge/pkg-plist8
4 files changed, 46 insertions, 0 deletions
diff --git a/www/p5-WWW-SourceForge/Makefile b/www/p5-WWW-SourceForge/Makefile
new file mode 100644
index 000000000000..33246f04e1e8
--- /dev/null
+++ b/www/p5-WWW-SourceForge/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: www/p5-WWW-SourceForge
+# Date created: 21 Oct 2004
+# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.idv.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-SourceForge
+PORTVERSION= 0.083
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ychsiao@ychsiao.idv.tw
+COMMENT= Retrieve infromation from SourceForge site
+
+BUILD_DEPENDS= ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
+ ${SITE_PERL}/HTML/TableExtract.pm:${PORTSDIR}/www/p5-HTML-TableExtract \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::SourceForge.3 WWW::SourceForge::Project.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-SourceForge/distinfo b/www/p5-WWW-SourceForge/distinfo
new file mode 100644
index 000000000000..fef0945c0ed7
--- /dev/null
+++ b/www/p5-WWW-SourceForge/distinfo
@@ -0,0 +1,2 @@
+MD5 (WWW-SourceForge-0.083.tar.gz) = e714ab19299bcb2ac2b53f027b82c48f
+SIZE (WWW-SourceForge-0.083.tar.gz) = 5559
diff --git a/www/p5-WWW-SourceForge/pkg-descr b/www/p5-WWW-SourceForge/pkg-descr
new file mode 100644
index 000000000000..c4c76537c693
--- /dev/null
+++ b/www/p5-WWW-SourceForge/pkg-descr
@@ -0,0 +1,9 @@
+This package helps to retrieve SourceForge site information in a perl script.
+
+So far, can only get very basic information. The goal is to be able to fetch
+Tracker and Mailing list data. Please send any suggestions directly to me.
+
+Use at your own risk, the author is not responsible to any damage caused by
+using this package.
+
+WWW: http://search.cpan.org/dist/WWW-SourceForge/
diff --git a/www/p5-WWW-SourceForge/pkg-plist b/www/p5-WWW-SourceForge/pkg-plist
new file mode 100644
index 000000000000..3b93a9d6b341
--- /dev/null
+++ b/www/p5-WWW-SourceForge/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/WWW/SourceForge.pm
+%%SITE_PERL%%/WWW/SourceForge/Project.pm
+%%SITE_PERL%%/WWW/SourceForge/User.pm
+@dirrm %%SITE_PERL%%/WWW/SourceForge
+@unexec rmdir %D/%%SITE_PERL%%/WWW 2>/dev/null || true
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/SourceForge/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/SourceForge
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW 2>/dev/null || true