aboutsummaryrefslogtreecommitdiffstats
path: root/www/planet
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-20 17:07:41 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-20 17:07:41 +0800
commit4f5b41a397c2be4fe6d80d2ea9d21772e67597d4 (patch)
tree6220171d01284d4f16c6c6e452066261f2e99ee2 /www/planet
parent18393b71cc5486d88d0fdb92b7a2ea79c893d760 (diff)
downloadfreebsd-ports-gnome-4f5b41a397c2be4fe6d80d2ea9d21772e67597d4.tar.gz
freebsd-ports-gnome-4f5b41a397c2be4fe6d80d2ea9d21772e67597d4.tar.zst
freebsd-ports-gnome-4f5b41a397c2be4fe6d80d2ea9d21772e67597d4.zip
- Support staging
- Convert USE_BZIP2=yes to USES=tar:bzip2 - Use COPYTREE_SHARE istead of CP - Revert deprecation, distfile is fetchable again
Diffstat (limited to 'www/planet')
-rw-r--r--www/planet/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/www/planet/Makefile b/www/planet/Makefile
index 264a71429ab0..414e4e960b9a 100644
--- a/www/planet/Makefile
+++ b/www/planet/Makefile
@@ -12,25 +12,18 @@ COMMENT= Planet is a flexible feed aggregator - and more!
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/Tidy/Tidy.py:${PORTSDIR}/devel/py-mx-experimental \
${PYTHON_PKGNAMEPREFIX}bsddb>0:${PORTSDIR}/databases/py-bsddb
-DEPRECATED= distfiles no longer fetchable
-EXPIRATION_DATE= 2014-04-01
-
-USE_BZIP2= yes
+USES= tar:bzip2
NO_BUILD= yes
USE_PYTHON= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-NO_STAGE= yes
post-extract:
@${RM} ${WRKSRC}/.bzrignore
@${FIND} ${WRKSRC}/ -type d -name '.bzr' | ${XARGS} ${RM} -rf
do-install:
- ${MKDIR} ${PREFIX}/share/planet
- ${CP} -R ${WRKSRC}/ ${PREFIX}/share/planet
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>