aboutsummaryrefslogtreecommitdiffstats
path: root/www/plugger
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
committermezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
commit867a335b88f91d457005fa0c7b3bb7c85c5fca14 (patch)
tree68af898c9a11dd756c516c49a6715cee75888e70 /www/plugger
parent6f64cd00171c29c1c7cdfb1e40393e23fc35151d (diff)
downloadfreebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.gz
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.zst
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'www/plugger')
-rw-r--r--www/plugger/Makefile10
-rw-r--r--www/plugger/pkg-plist4
2 files changed, 9 insertions, 5 deletions
diff --git a/www/plugger/Makefile b/www/plugger/Makefile
index 793a4f9e469d..cf546ef27840 100644
--- a/www/plugger/Makefile
+++ b/www/plugger/Makefile
@@ -7,7 +7,7 @@
PORTNAME= plugger
PORTVERSION= 5.1.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www audio graphics multimedia
MASTER_SITES= http://fredrik.hubbe.net/plugger/
@@ -20,7 +20,11 @@ GNU_CONFIGURE= yes
MAN7= plugger.7
PKGDEINSTALL= ${PKGINSTALL}
+USE_WEBPLUGINS= native
+WEBPLUGINS_FILES=npplugger.so
+
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
post-patch:
@${REINPLACE_CMD} -e \
@@ -39,9 +43,9 @@ do-install:
${PREFIX}/bin
@${INSTALL_SCRIPT} ${WRKSRC}/plugger-oohelper \
${PREFIX}/bin
- @${MKDIR} ${PREFIX}/lib/browser_plugins
+ @${MKDIR} ${WEBPLUGINS_DIR}
@${INSTALL_PROGRAM} ${WRKSRC}/plugger.so \
- ${PREFIX}/lib/browser_plugins/npplugger.so
+ ${WEBPLUGINS_DIR}/npplugger.so
@if [ -f ${PREFIX}/etc/pluggerrc-${PORTVERSION} ]; then \
${MV} ${PREFIX}/etc/pluggerrc-${PORTVERSION} \
${PREFIX}/etc/pluggerrc-${PORTVERSION}.old; \
diff --git a/www/plugger/pkg-plist b/www/plugger/pkg-plist
index 2974fb3c4e8c..75689318588e 100644
--- a/www/plugger/pkg-plist
+++ b/www/plugger/pkg-plist
@@ -3,5 +3,5 @@ bin/plugger-controller
bin/plugger-oohelper
@unexec if cmp %D/etc/pluggerrc-5.1.3.sample %D/etc/pluggerrc-5.1.3 2>/dev/null; then rm -f %D/etc/pluggerrc-5.1.3; fi
etc/pluggerrc-5.1.3.sample
-lib/browser_plugins/npplugger.so
-@dirrmtry lib/browser_plugins
+%%WEBPLUGINS_DIR%%/npplugger.so
+@dirrmtry %%WEBPLUGINS_DIR%%