aboutsummaryrefslogtreecommitdiffstats
path: root/www/protovis
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-01-17 21:08:29 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-01-17 21:08:29 +0800
commit635786bcbe2844715cde1cdc308eba6f14bec73c (patch)
tree905d9a2e5dad746c32883e4e1bacc8f4221f9644 /www/protovis
parentcf5d2c90c0a36d48939f736d12a217476210133d (diff)
downloadfreebsd-ports-gnome-635786bcbe2844715cde1cdc308eba6f14bec73c.tar.gz
freebsd-ports-gnome-635786bcbe2844715cde1cdc308eba6f14bec73c.tar.zst
freebsd-ports-gnome-635786bcbe2844715cde1cdc308eba6f14bec73c.zip
- Add NO_ARCH
- Add PORTSCOUT - Convert to new options target helper Sponsored by: PortsCamp Taiwan
Diffstat (limited to 'www/protovis')
-rw-r--r--www/protovis/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/protovis/Makefile b/www/protovis/Makefile
index 780200b83d81..bc4bd134f811 100644
--- a/www/protovis/Makefile
+++ b/www/protovis/Makefile
@@ -13,6 +13,9 @@ LICENSE= BSD3CLAUSE
OPTIONS_DEFINE= EXAMPLES
+PORTSCOUT= limit:^v[0-9\.]*$$
+
+NO_ARCH= yes
NO_BUILD= yes
PORTEXAMPLES= *
@@ -21,8 +24,11 @@ GH_ACCOUNT= mbostock
USE_GITHUB= yes
do-install:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/ ${STAGEDIR}${WWWDIR}/
+ ${MKDIR} ${STAGEDIR}${WWWDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} *.js ${STAGEDIR}${WWWDIR}/
+
+do-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}/
.include <bsd.port.mk>