aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-dj21-django-timezone-field
diff options
context:
space:
mode:
authorkai <kai@FreeBSD.org>2019-05-25 18:10:01 +0800
committerkai <kai@FreeBSD.org>2019-05-25 18:10:01 +0800
commit198367af3f93bb85aa0dcaba0668714fe5a88dde (patch)
treeb1a569017550f067839a8b1f0d8048546ff6801b /www/py-dj21-django-timezone-field
parent5e57216867da3d585e069910473551622417a060 (diff)
downloadfreebsd-ports-gnome-198367af3f93bb85aa0dcaba0668714fe5a88dde.tar.gz
freebsd-ports-gnome-198367af3f93bb85aa0dcaba0668714fe5a88dde.tar.zst
freebsd-ports-gnome-198367af3f93bb85aa0dcaba0668714fe5a88dde.zip
net-mgmt/netbox: Update to 2.5.12 and switch to Django 2.2
Upstream decided to switch from Django 2.1 to the 2.2 LTS release to fix a rather annoying bug that generated intermittent errors when objects were deleted/manipulated. Therefore the same procedure must be done in almost the same way as in r492690 to make NetBox compatible with Django 2.2 in the ports tree. That means to repocopy the required Django 1.11 ports, assign them to Django 2.2, limit them to Python 3.5+ and update all related CONFLICTS_INSTALL entries accordingly: * www/py-dj22-django-cors-headers [1] * www/py-dj22-django-debug-toolbar * www/py-dj22-django-filter * www/py-dj22-django-js-asset * www/py-dj22-django-mptt * www/py-dj22-django-tables2 * www/py-dj22-django-taggit-serializer * www/py-dj22-django-timezone-field * www/py-dj22-drf-yasg [1] www/py-django-cors-headers was repocopied from r500510 to keep on the 2.5.x branch as 3.x introduced some backward incompatibilities that haven't been fully tested, yet. Changelog since 2.5.10: Enhancements: * Improve natural ordering of device components * Add support for filtering cables by connected device * Add decommissioning status for devices Bug Fixes: * Fix natural ordering of device components (after it has been improved before) * Upgrade Django requirement to 2.2 to fix object deletion issue in the changelog middleware * Preserve multiselect filter values when updating per-page count for list views * Fix ordering of interface connections list by termination B name/device * Fix tagged_items count in tags API endpoint * Disable last_login update on login when maintenance mode is enabled Reviewed by: koobs, miwi Differential Revision: https://reviews.freebsd.org/D20103
Diffstat (limited to 'www/py-dj21-django-timezone-field')
-rw-r--r--www/py-dj21-django-timezone-field/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/www/py-dj21-django-timezone-field/Makefile b/www/py-dj21-django-timezone-field/Makefile
index 3e3ffe44b006..e130be05de8d 100644
--- a/www/py-dj21-django-timezone-field/Makefile
+++ b/www/py-dj21-django-timezone-field/Makefile
@@ -19,6 +19,7 @@ USES= python:3.5+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
-CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}django-timezone-field
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}django-timezone-field \
+ ${PYTHON_PKGNAMEPREFIX}dj22-django-timezone-field
.include <bsd.port.mk>