aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-django/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-11-26 04:16:12 +0800
committerpav <pav@FreeBSD.org>2005-11-26 04:16:12 +0800
commit261b1c96b55067b2075c365e7c5228b18d4b4875 (patch)
tree9256fdf64f3612680383d314188bf8598f94616d /www/py-django/Makefile
parentb9e3accf082aef19d672e864df2341a6524906ad (diff)
downloadfreebsd-ports-gnome-261b1c96b55067b2075c365e7c5228b18d4b4875.tar.gz
freebsd-ports-gnome-261b1c96b55067b2075c365e7c5228b18d4b4875.tar.zst
freebsd-ports-gnome-261b1c96b55067b2075c365e7c5228b18d4b4875.zip
Django is a high-level Python Web framework that encourages rapid development
and clean, pragmatic design. Developed and used over the past two years by a fast-moving online-news operation, Django was designed from scratch to handle two challenges: the intensive deadlines of a newsroom and the stringent requirements of experienced Web developers. It has convenient niceties for developing content-management systems, but it's an excellent tool for building any Web site. PR: ports/89437 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Diffstat (limited to 'www/py-django/Makefile')
-rw-r--r--www/py-django/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/www/py-django/Makefile b/www/py-django/Makefile
new file mode 100644
index 000000000000..ea624be5d358
--- /dev/null
+++ b/www/py-django/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: django
+# Date created: 2005-11-19
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= django
+PORTVERSION= 0.90
+CATEGORIES= www python
+MASTER_SITES= http://media.djangoproject.com/releases/0.90/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Django-${PORTVERSION}
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= High-level Python Web framework
+
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+
+DIST_SUBDIR= python
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= yes
+NO_BUILD= yes
+DOCSDIR= ${PREFIX}/share/doc/py-django
+
+OPTIONS= MOD_PYTHON3 "Install Apache2 with mod_python3" off \
+ POSTGRESQL "PostgreSQL support" off \
+ MYSQL "MySQL support" off \
+ SQLITE "SQLite support" off
+
+# bypass infrastructure bug
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MOD_PYTHON3)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/mod_python/_psp.so:${PORTSDIR}/www/mod_python3
+.endif
+
+.if defined(WITH_POSTGRESQL)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopgmodule.so:${PORTSDIR}/databases/py-psycopg
+.endif
+
+.if defined(WITH_MYSQL)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_mysql.so:${PORTSDIR}/databases/py-MySQLdb
+.endif
+
+.if defined(WITH_SQLITE)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite.so:${PORTSDIR}/databases/py-PySQLite2
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " * See ${DOCSDIR} for complete documentation"
+ @${ECHO_MSG} ""
+.else
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " * See http://www.djangoproject.com/documentation/ for complete documentation"
+ @${ECHO_MSG} ""
+.endif
+
+.include <bsd.port.post.mk>