aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-django/Makefile
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-03-31 14:50:11 +0800
committerclsung <clsung@FreeBSD.org>2007-03-31 14:50:11 +0800
commit3f62135c486400ce7decb229170d91c23d267277 (patch)
treec9d787a54227aa16a58233bed4a38cdf40c5123f /www/py-django/Makefile
parent677a14d2ea2369690df0a4885feb86108ce12381 (diff)
downloadfreebsd-ports-gnome-3f62135c486400ce7decb229170d91c23d267277.tar.gz
freebsd-ports-gnome-3f62135c486400ce7decb229170d91c23d267277.tar.zst
freebsd-ports-gnome-3f62135c486400ce7decb229170d91c23d267277.zip
- Update to 0.96
PR: ports/111049 Submitted by: Li-Wen Hsu <lwhsu_AT_lwhsu dot org>
Diffstat (limited to 'www/py-django/Makefile')
-rw-r--r--www/py-django/Makefile18
1 files changed, 3 insertions, 15 deletions
diff --git a/www/py-django/Makefile b/www/py-django/Makefile
index ad37e28fe7cb..27cda54e24df 100644
--- a/www/py-django/Makefile
+++ b/www/py-django/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME?= django
-PORTVERSION?= 0.95.1
-PORTREVISION?= 1
+PORTVERSION?= 0.96
CATEGORIES= www python
-MASTER_SITES?= http://media.djangoproject.com/releases/${PORTVERSION:R}/
+MASTER_SITES?= http://media.djangoproject.com/releases/${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= Django-${PORTVERSION}
DIST_SUBDIR= python
@@ -17,23 +16,12 @@ DIST_SUBDIR= python
MAINTAINER?= python@FreeBSD.org
COMMENT= High-level Python Web framework
-BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
USE_GETTEXT= yes
-USE_PYTHON= 2.3+
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
-EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
-
DOCSDIR= ${PREFIX}/share/doc/py-django
-PYDJANGO_EGG= Django-${PORTVERSION}-py${PYTHON_VER}.egg
-
-PLIST_SUB= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
- PYDJANGO_EGG=${PYDJANGO_EGG} \
- PYDJANGO_EGG_VER="Django==${PORTVERSION}"
-
OPTIONS= MOD_PYTHON3 "Install Apache2 with mod_python3" off \
POSTGRESQL "PostgreSQL support" off \
MYSQL "MySQL support" off \