aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-django110
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-02-08 04:32:04 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-02-08 04:32:04 +0800
commit1b7218736327283fd6859a1ed3773c7d464ab4cc (patch)
treeb158cf248d3ff6b2dc63972881aef09460c423d6 /www/py-django110
parentd55d2a5359bda962179d2b9c3458202b7b097ee7 (diff)
downloadfreebsd-ports-gnome-1b7218736327283fd6859a1ed3773c7d464ab4cc.tar.gz
freebsd-ports-gnome-1b7218736327283fd6859a1ed3773c7d464ab4cc.tar.zst
freebsd-ports-gnome-1b7218736327283fd6859a1ed3773c7d464ab4cc.zip
Update to 1.10.5
- Add NO_ARCH - Add missing OPTIONS_DEFINE=DOCS - Convert to options helper - Convert to options target helper - Update WWW Changes: https://docs.djangoproject.com/en/1.10/releases/1.10.5/
Diffstat (limited to 'www/py-django110')
-rw-r--r--www/py-django110/Makefile19
-rw-r--r--www/py-django110/distinfo6
-rw-r--r--www/py-django110/pkg-descr2
3 files changed, 12 insertions, 15 deletions
diff --git a/www/py-django110/Makefile b/www/py-django110/Makefile
index 0e62556820e8..cba22db485f9 100644
--- a/www/py-django110/Makefile
+++ b/www/py-django110/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= django
-PORTVERSION= 1.10.4
+PORTVERSION= 1.10.5
CATEGORIES= www python
MASTER_SITES= CHEESESHOP \
https://www.djangoproject.com/m/releases/${PORTVERSION}/
@@ -17,6 +17,7 @@ COMMENT= High-level Python Web Framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+NO_ARCH= yes
USES= cpe python
USE_PYTHON= autoplist distutils
@@ -25,7 +26,7 @@ CPE_VENDOR= djangoproject
DOCSDIR= ${PREFIX}/share/doc/py-django
-OPTIONS_DEFINE= FASTCGI HTMLDOCS
+OPTIONS_DEFINE= DOCS FASTCGI HTMLDOCS
OPTIONS_DEFAULT= SQLITE
OPTIONS_GROUP= DATABASE
@@ -35,6 +36,7 @@ HTMLDOCS_DESC= Install HTML documentation (requires Sphinx)
PLIST_FILES= man/man1/django-admin.1.gz
+HTMLDOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx
PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:databases/py-psycopg2
MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb
SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
@@ -42,27 +44,22 @@ FASTCGI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flup>0:www/py-flup
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MHTMLDOCS}
-. if empty(PORT_OPTIONS:MDOCS)
+.if ${PORT_OPTIONS:MHTMLDOCS} && empty(PORT_OPTIONS:MDOCS)
IGNORE= you cannot build documentation with DOCS option disabled
-. endif
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx
PORTDOCS= *
.endif
-post-build:
-.if ${PORT_OPTIONS:MHTMLDOCS}
+post-build-HTMLDOCS-on:
cd ${WRKSRC}/docs && ${MAKE} html
-.endif
post-install:
${INSTALL_MAN} ${WRKSRC}/docs/man/* ${STAGEDIR}/${MAN1PREFIX}/man/man1
@${ECHO_MSG} ""
@${ECHO_MSG} " * See http://docs.djangoproject.com/ for complete documentation"
@${ECHO_MSG} ""
-.if ${PORT_OPTIONS:MHTMLDOCS}
+
+post-install-HTMLDOCS-on:
${MKDIR} ${STAGEDIR}/${DOCSDIR}
${CP} -R ${WRKSRC}/docs/_build/html ${STAGEDIR}/${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/www/py-django110/distinfo b/www/py-django110/distinfo
index 495e87085869..93adf72fe88c 100644
--- a/www/py-django110/distinfo
+++ b/www/py-django110/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480861696
-SHA256 (python/Django-1.10.4.tar.gz) = fff7f062e510d812badde7cfc57745b7779edb4d209b2bc5ea8d954c22305c2b
-SIZE (python/Django-1.10.4.tar.gz) = 7735213
+TIMESTAMP = 1486481170
+SHA256 (python/Django-1.10.5.tar.gz) = 0db89374b691b9c8b057632a6cd64b18d08db2f4d63b4d4af6024267ab965f8b
+SIZE (python/Django-1.10.5.tar.gz) = 7734715
diff --git a/www/py-django110/pkg-descr b/www/py-django110/pkg-descr
index 638401f81c0e..0ea493b87ab6 100644
--- a/www/py-django110/pkg-descr
+++ b/www/py-django110/pkg-descr
@@ -7,4 +7,4 @@ intensive deadlines of a newsroom and the stringent requirements of experienced
Web developers. It has convenient niceties for developing content-management
systems, but it's an excellent tool for building any Web site.
-WWW: http://www.djangoproject.com
+WWW: https://www.djangoproject.com/