aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-planet
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2017-09-15 15:12:44 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-09-15 15:12:44 +0800
commitab1f40794d9dbcc1388a9257d285362f52f74596 (patch)
tree2a6a7e2dc039c429914eaca76a443556bf403df2 /www/py-planet
parentfd6770ac21bfbaf4055314e3e44262e074d8043b (diff)
parent26f34f6d62441f81a8d0d43f1908a496c283ee05 (diff)
downloadfreebsd-ports-gnome-gnome-3.24.tar.gz
freebsd-ports-gnome-gnome-3.24.tar.zst
freebsd-ports-gnome-gnome-3.24.zip
Merge branch 'master' into gnome-3.24gnome-3.24
Diffstat (limited to 'www/py-planet')
-rw-r--r--www/py-planet/Makefile22
-rw-r--r--www/py-planet/distinfo3
-rw-r--r--www/py-planet/pkg-descr7
3 files changed, 32 insertions, 0 deletions
diff --git a/www/py-planet/Makefile b/www/py-planet/Makefile
new file mode 100644
index 000000000000..d90c5bef226d
--- /dev/null
+++ b/www/py-planet/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= planet
+PORTVERSION= 1.0.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python client library and CLI for Planet's public API #'
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=0:devel/py-click \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}requests-futures>=0:www/py-requests-futures
+
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/www/py-planet/distinfo b/www/py-planet/distinfo
new file mode 100644
index 000000000000..657ab9bee031
--- /dev/null
+++ b/www/py-planet/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1505229319
+SHA256 (planet-1.0.1.tar.gz) = a6a10b1b8de1493d82a27d8fe27a8611fffce193bce57ff7ec59941a925be534
+SIZE (planet-1.0.1.tar.gz) = 27185
diff --git a/www/py-planet/pkg-descr b/www/py-planet/pkg-descr
new file mode 100644
index 000000000000..d8f9e0b646b7
--- /dev/null
+++ b/www/py-planet/pkg-descr
@@ -0,0 +1,7 @@
+This library provides a command-line-interface (CLI) and Python library to make
+access to Planet's public API easy to use.
+
+The command line interface is intended to be functional for many tasks but is
+just a thin layer on the lower level Python API.
+
+WWW: https://pypi.python.org/pypi/planet