aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-qt5-webkit
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /www/py-qt5-webkit
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadfreebsd-ports-gnome-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
freebsd-ports-gnome-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.zst
freebsd-ports-gnome-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'www/py-qt5-webkit')
-rw-r--r--www/py-qt5-webkit/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/py-qt5-webkit/Makefile b/www/py-qt5-webkit/Makefile
index c01856bf94ca..021d74f513c7 100644
--- a/www/py-qt5-webkit/Makefile
+++ b/www/py-qt5-webkit/Makefile
@@ -7,8 +7,8 @@ CATEGORIES= www devel python
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt5 toolkit, QtWebKit module
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:devel/py-sip
-RUN_DEPENDS= ${PKGNAMEPREFIX}gui>=${PYQT5_VERSION}:x11-toolkits/py-qt5-gui
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:devel/py-sip@${FLAVOR}
+RUN_DEPENDS= ${PKGNAMEPREFIX}gui>=${PYQT5_VERSION}:x11-toolkits/py-qt5-gui@${FLAVOR}
CONFIGURE_ARGS= --enable QtWebKit
PYQT_DIST= yes
@@ -16,6 +16,7 @@ PYQT_DIST= yes
USES= python pyqt:5
USE_GL= gl
USE_PYQT= sip_build core_run gui_run network_run
+USE_PYTHON= flavors
USE_QT5= core gui network webkit qmake_build
OPTIONS_DEFINE= API DEBUG