aboutsummaryrefslogtreecommitdiffstats
path: root/www/quickie
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-06-20 20:54:52 +0800
committershaun <shaun@FreeBSD.org>2006-06-20 20:54:52 +0800
commit6c8efd49e890d1c023fdeb335e3fc00cd84890a9 (patch)
treedec260297c29ef96ec36a9b1c0a737f009c92b0d /www/quickie
parenta24db8d9d73a05df6ff4e21d07670ccb20854200 (diff)
downloadfreebsd-ports-gnome-6c8efd49e890d1c023fdeb335e3fc00cd84890a9.tar.gz
freebsd-ports-gnome-6c8efd49e890d1c023fdeb335e3fc00cd84890a9.tar.zst
freebsd-ports-gnome-6c8efd49e890d1c023fdeb335e3fc00cd84890a9.zip
Fix dodgy patch - send correct Content-Length: header.
PR: ports/99075 Submitted by: Nikolai Saoukh <nms+freebsd@otdel-1.org> Approved by: shaun (me), ahze (mentor)
Diffstat (limited to 'www/quickie')
-rw-r--r--www/quickie/Makefile1
-rw-r--r--www/quickie/files/patch-lib_file_regular.cc18
2 files changed, 13 insertions, 6 deletions
diff --git a/www/quickie/Makefile b/www/quickie/Makefile
index 279d6201e8be..959864ae963c 100644
--- a/www/quickie/Makefile
+++ b/www/quickie/Makefile
@@ -7,6 +7,7 @@
PORTNAME= quickie
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://${PORTNAME}.sourceforge.net/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
diff --git a/www/quickie/files/patch-lib_file_regular.cc b/www/quickie/files/patch-lib_file_regular.cc
index 53ed768dd175..74a5b4178ee5 100644
--- a/www/quickie/files/patch-lib_file_regular.cc
+++ b/www/quickie/files/patch-lib_file_regular.cc
@@ -12,12 +12,18 @@
#include <careful.h>
#include <cgi.h>
#include <configuration.h>
-@@ -386,7 +391,7 @@
+@@ -384,11 +389,8 @@
+ return;
+ }
output_stdout op;
- op << "Content-Type: text/html\n"
- "Content-Length: "
+- op << "Content-Type: text/html\n"
+- "Content-Length: "
- << st.st_size
-+ << (char)st.st_size
- << "\n"
- "\n";
+- << "\n"
+- "\n";
++ op << "Content-Type: text/html\n";
++ op.printf("Content-Length: %llu\n\n", st.st_size);
for (;;)
+ {
+ char buffer[1 << 14];
+