aboutsummaryrefslogtreecommitdiffstats
path: root/www/resin2/files
diff options
context:
space:
mode:
authorznerd <znerd@FreeBSD.org>2003-10-01 19:20:42 +0800
committerznerd <znerd@FreeBSD.org>2003-10-01 19:20:42 +0800
commit3a57c14399120a0b1b662939b764861473788c73 (patch)
treee41d95540f2679ea17835fb9294441273557fd25 /www/resin2/files
parent44e000ece53cbb4888db643f1b96acb7c4fd43b6 (diff)
downloadfreebsd-ports-gnome-3a57c14399120a0b1b662939b764861473788c73.tar.gz
freebsd-ports-gnome-3a57c14399120a0b1b662939b764861473788c73.tar.zst
freebsd-ports-gnome-3a57c14399120a0b1b662939b764861473788c73.zip
New port: Resin 2.
Submitted by: Jean-Baptiste Quenot <jb.quenot@caraldi.com>
Diffstat (limited to 'www/resin2/files')
-rw-r--r--www/resin2/files/patch-Makefile.in11
-rw-r--r--www/resin2/files/patch-apache211
-rw-r--r--www/resin2/files/patch-httpd.sh34
-rw-r--r--www/resin2/files/patch-install-apache10
-rw-r--r--www/resin2/files/patch-install-apache211
-rw-r--r--www/resin2/files/patch-resin.conf11
6 files changed, 88 insertions, 0 deletions
diff --git a/www/resin2/files/patch-Makefile.in b/www/resin2/files/patch-Makefile.in
new file mode 100644
index 000000000000..5754ce64ac6d
--- /dev/null
+++ b/www/resin2/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- src/c/plugin/resin/Makefile.in.orig Fri Feb 14 21:48:23 2003
++++ src/c/plugin/resin/Makefile.in Wed Mar 5 19:11:12 2003
+@@ -20,7 +20,7 @@
+ all : resin libresin.$(SO)
+
+ resin : resin.o $(OBJ)
+- $(CC) $(LDFLAGS) -o $@ resin.o $(OBJ) $(PROXY_LIBS) -ldl
++ $(CC) $(LDFLAGS) -o $@ resin.o $(OBJ) $(PROXY_LIBS)
+
+ resin_so : libresin.$(SO)
+
diff --git a/www/resin2/files/patch-apache2 b/www/resin2/files/patch-apache2
new file mode 100644
index 000000000000..2130da28e974
--- /dev/null
+++ b/www/resin2/files/patch-apache2
@@ -0,0 +1,11 @@
+--- src/c/plugin/apache2/mod_caucho.c.orig Tue Apr 15 23:28:46 2003
++++ src/c/plugin/apache2/mod_caucho.c Fri Jun 6 01:37:29 2003
+@@ -52,7 +52,7 @@
+ #include "cse.h"
+ #include "version.h"
+
+-#ifndef APR_HAS_THREADS
++#if !APR_HAS_THREADS
+ #define apr_thread_mutex_t int
+ #define apr_thread_mutex_create(a,b,c)
+ #define apr_thread_mutex_lock(a)
diff --git a/www/resin2/files/patch-httpd.sh b/www/resin2/files/patch-httpd.sh
new file mode 100644
index 000000000000..0eb3b58dd55b
--- /dev/null
+++ b/www/resin2/files/patch-httpd.sh
@@ -0,0 +1,34 @@
+--- bin/httpd.sh.orig Tue Apr 15 23:28:50 2003
++++ bin/httpd.sh Thu Jul 24 14:35:36 2003
+@@ -37,11 +37,8 @@
+ #
+ # You can predefine JAVA_HOME and RESIN_HOME
+ #
+-# JAVA_HOME=/usr/java
+-# export JAVA_HOME
+-#
+-# RESIN_HOME=/usr/local/resin
+-# export RESIN_HOME
++export JAVA_HOME=%%JAVA_HOME%%
++export RESIN_HOME=%%PREFIX%%/%%PKGNAMEPREFIX%%%%PORTNAME%%
+ #
+ # Extra arguments to Java. If you're passing arguments to the JVM, you'll
+ # need to use -Jxxx. For example, args="-J-ms48m". You can modify
+@@ -61,16 +58,4 @@
+ #
+ perl=perl
+
+-#
+-# trace script and simlinks to find thw wrapper
+-#
+-script=`/bin/ls -l $0 | awk '{ print $NF; }'`
+-
+-while test -h "$script"
+-do
+- script=`/bin/ls -l $script | awk '{ print $NF; }'`
+-done
+-
+-bin=`dirname $script`
+-
+-exec $perl $bin/wrapper.pl -chdir -name "$name" -class "$class" $args $*
++su -f -m www -c "exec $perl %%PREFIX%%/sbin/resinctl -conf %%PREFIX%%/etc/resin.xml -chdir -name "$name" -class "$class" $args $*" > /dev/null && echo -n '%%PKGNAMEPREFIX%%%%PORTNAME%% '
diff --git a/www/resin2/files/patch-install-apache b/www/resin2/files/patch-install-apache
new file mode 100644
index 000000000000..42482c94dc9a
--- /dev/null
+++ b/www/resin2/files/patch-install-apache
@@ -0,0 +1,10 @@
+--- src/c/plugin/apache/install.sh.orig Fri Jul 25 15:34:33 2003
++++ src/c/plugin/apache/install.sh Fri Jul 25 15:35:53 2003
+@@ -51,6 +51,6 @@
+
+ LoadModule caucho_module $LIBEXECDIR/mod_caucho.so
+
+-CauchoConfigFile $RESIN_HOME/conf/resin.conf
++CauchoConfigFile %%PREFIX%%/etc/resin.xml
+ EOF
+ fi
diff --git a/www/resin2/files/patch-install-apache2 b/www/resin2/files/patch-install-apache2
new file mode 100644
index 000000000000..98d826a6c83f
--- /dev/null
+++ b/www/resin2/files/patch-install-apache2
@@ -0,0 +1,11 @@
+--- src/c/plugin/apache2/install.sh.orig Fri Jul 25 15:34:39 2003
++++ src/c/plugin/apache2/install.sh Fri Jul 25 15:35:53 2003
+@@ -51,7 +51,7 @@
+
+ LoadModule caucho_module $LIBEXECDIR/mod_caucho.so
+
+-CauchoConfigFile $RESIN_HOME/conf/resin.conf
++CauchoConfigFile %%PREFIX%%/etc/resin.xml
+ EOF
+
+ fi
diff --git a/www/resin2/files/patch-resin.conf b/www/resin2/files/patch-resin.conf
new file mode 100644
index 000000000000..a90a144e6c7c
--- /dev/null
+++ b/www/resin2/files/patch-resin.conf
@@ -0,0 +1,11 @@
+--- conf/resin.conf.orig Thu Mar 6 10:19:07 2003
++++ conf/resin.conf Wed Mar 5 21:05:50 2003
+@@ -67,7 +67,7 @@
+ <doc-dir>doc</doc-dir>
+
+ <!-- the http port -->
+- <http port='8080'/>
++ <http port='%%PORT%%'/>
+
+ <!--
+ - The srun port, read by both JVM and plugin