aboutsummaryrefslogtreecommitdiffstats
path: root/www/resin3/Makefile
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-01-26 18:23:38 +0800
committerclement <clement@FreeBSD.org>2004-01-26 18:23:38 +0800
commitf2f97172676855e31150b8b4e6e6bf842e55b208 (patch)
tree205667fd0e7020d7a0a7c16ceca092ce5b8068d8 /www/resin3/Makefile
parent09199effc02fbcd38a328880372c0c1e6a3cc3b1 (diff)
downloadfreebsd-ports-gnome-f2f97172676855e31150b8b4e6e6bf842e55b208.tar.gz
freebsd-ports-gnome-f2f97172676855e31150b8b4e6e6bf842e55b208.tar.zst
freebsd-ports-gnome-f2f97172676855e31150b8b4e6e6bf842e55b208.zip
- Update to 3.0.6
PR: 61766 [1] Submitted by: Xin LI <delphij@frontfree.net> [1], Jean-Baptiste Quenot <jb.quenot@caraldi.com> (maintainer)
Diffstat (limited to 'www/resin3/Makefile')
-rw-r--r--www/resin3/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 74b028245d07..011a7b145c7b 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= resin
-PORTVERSION= 3.0.3
-PORTREVISION= 1
+PORTVERSION= 3.0.6
CATEGORIES= www java
MASTER_SITES= http://www.caucho.com/download/
@@ -53,6 +52,7 @@ REPLACE_FILES= ${FILESDIR}/pkg-install \
${WRKSRC}/conf/resin.conf \
${WRKSRC}/bin/wrapper.pl.in \
${FILESDIR}/resin.sh.in
+COPYDIRS= doc lib webapps xsl
# Pass JAVA_HOME as determined by bsd.java.mk
CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME}
@@ -88,6 +88,7 @@ PLIST_SUB+= APXS=${APXS}
SUBSTITUTIONS= -e "s|%%APP_HOME%%|${APP_HOME}|g" \
-e "s|%%APP_NAME%%|${APP_NAME}|g" \
-e "s|%%APXS%%|${APXS}|g" \
+ -e "s|%%COPYDIRS%%|${COPYDIRS}|g" \
-e "s|%%FILESDIR%%|${FILESDIR}|g" \
-e "s|%%GROUP%%|${GROUP}|g" \
-e "s|%%GID%%|${GID}|g" \
@@ -116,9 +117,9 @@ post-patch:
defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
@${ECHO_CMD} >> ${PKGMESSAGE}
@${ECHO_CMD} The Resin Apache module mod_caucho has been activated \
- in the Apache configuration file, where you should also \
- add a line to specify the location of the Resin configuration \
- server, for example: | fmt -w 80 >> ${PKGMESSAGE}
+ in the Apache configuration file, where you should also \
+ add a line to specify the location of the Resin configuration \
+ server, for example: | fmt -w 80 >> ${PKGMESSAGE}
@${ECHO_CMD} ResinConfigServer localhost 6802 >> ${PKGMESSAGE}
.endif
@${MV} ${WRKDIR}/wrapper.pl.in ${WRKSRC}/bin/wrapper.pl.in