aboutsummaryrefslogtreecommitdiffstats
path: root/www/rt34/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2003-05-08 22:36:40 +0800
committerdemon <demon@FreeBSD.org>2003-05-08 22:36:40 +0800
commit65a91e0da95a52a64c27a4757357d6a62cedc634 (patch)
treeabea9eeaacb35f52d5f49201c0747e1cef6c9484 /www/rt34/Makefile
parent82cf864bc18dd69f3faea04ba4c212848f4a44f2 (diff)
downloadfreebsd-ports-gnome-65a91e0da95a52a64c27a4757357d6a62cedc634.tar.gz
freebsd-ports-gnome-65a91e0da95a52a64c27a4757357d6a62cedc634.tar.zst
freebsd-ports-gnome-65a91e0da95a52a64c27a4757357d6a62cedc634.zip
o Remove do-build: it is redundant if all dependencies are listed correctly;
o Change default user/group from nobody:nogroup to www:www; o Remove redundant '-f Makefile' from 'make' invocation; o Add NO_PACKAGE, since it executes scripts in post-install phase. Approved by: maintainer
Diffstat (limited to 'www/rt34/Makefile')
-rw-r--r--www/rt34/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/www/rt34/Makefile b/www/rt34/Makefile
index e92ffe898634..7470ff1fae1e 100644
--- a/www/rt34/Makefile
+++ b/www/rt34/Makefile
@@ -53,9 +53,12 @@ BUILD_DEPENDS= ${APXS}:${APACHE_PORT} \
${ARCH_PERL}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time \
${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
+RUN_DEPENDS= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/rt-3-0-1
HAS_CONFIGURE= yes
+NO_BUILD= yes
+NO_PACKAGE= Executes scripts in post-install phase
CONFIGURE_ARGS= --prefix=${RT_PATH} \
--enable-layout=${LAYOUT} \
@@ -91,8 +94,6 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/mysql_config:${PORTSDIR}/databases/mysql40-serv
TESTDEPS_ARGS+= --with-MYSQL
.endif
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
SITE_PERL:= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
ARCH_PERL= ${SITE_PERL}/${PERL_ARCH}/
USE_PERL5= yes
@@ -103,8 +104,8 @@ DB_DBA_USER?= root
DB_HOST?= localhost
DB_DBA_PASSWORD?=
-WEB_USER?= nobody
-WEB_GROUP?= nogroup
+WEB_USER?= www
+WEB_GROUP?= www
LIBS_GROUP?= wheel
RT_GROUP?= rt
@@ -125,11 +126,8 @@ post-extract:
-@pw groupadd ${RT_GROUP}
-@cd ${WRKSRC} && chmod a+x configure
-do-build:
- -@cd ${WRKSRC} && ${PERL} ./sbin/rt-test-dependencies --install ${TESTDEPS_ARGS}
-
do-install:
- @cd ${WRKSRC} && ${MAKE} -f ${WRKSRC}/Makefile install
+ @cd ${WRKSRC} && ${MAKE} install
@${INSTALL_DATA} ${WRKSRC}/README ${RT_PATH}/README
post-install: