aboutsummaryrefslogtreecommitdiffstats
path: root/www/rt34/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2004-07-26 18:51:03 +0800
committerdemon <demon@FreeBSD.org>2004-07-26 18:51:03 +0800
commit7a80b29e2f2a9ea6405669bd5e3af930f94fc934 (patch)
tree2c3e6fa6a29e28054c454924e2d497bb5dfd184c /www/rt34/Makefile
parent40554efb04a5cc7087f48af9ab7a9a0d31d2f73c (diff)
downloadfreebsd-ports-gnome-7a80b29e2f2a9ea6405669bd5e3af930f94fc934.tar.gz
freebsd-ports-gnome-7a80b29e2f2a9ea6405669bd5e3af930f94fc934.tar.zst
freebsd-ports-gnome-7a80b29e2f2a9ea6405669bd5e3af930f94fc934.zip
Add missing dependencies.
Diffstat (limited to 'www/rt34/Makefile')
-rw-r--r--www/rt34/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/rt34/Makefile b/www/rt34/Makefile
index 986daa827ddd..fb790d3144fc 100644
--- a/www/rt34/Makefile
+++ b/www/rt34/Makefile
@@ -45,7 +45,8 @@ BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT} \
${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules \
${SITE_PERL}/Tree/Simple.pm:${PORTSDIR}/devel/p5-Tree-Simple \
- ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
+ ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
+ ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS
RUN_DEPENDS= ${BUILD_DEPENDS}
HAS_CONFIGURE= yes
@@ -81,7 +82,8 @@ DEPENDS_ARGS+= WITHOUT_MODPERL=yes
DEPENDS_ARGS+= WITH_MODPERL2=yes
.else
# XXX - probe for static mod_perl using `httpd -l | grep perl`
-BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
+BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
.endif
.endif