aboutsummaryrefslogtreecommitdiffstats
path: root/www/sarg
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2012-03-18 19:37:48 +0800
committergarga <garga@FreeBSD.org>2012-03-18 19:37:48 +0800
commit0a3df6ed12a5a4d61347636e5f6c69484ea34736 (patch)
treeb300c793aefa3ae0fd06ec6eb45db429f56cbefb /www/sarg
parentff0f22784626e22afe1b290eaca9e300ba56caa1 (diff)
downloadfreebsd-ports-gnome-0a3df6ed12a5a4d61347636e5f6c69484ea34736.tar.gz
freebsd-ports-gnome-0a3df6ed12a5a4d61347636e5f6c69484ea34736.tar.zst
freebsd-ports-gnome-0a3df6ed12a5a4d61347636e5f6c69484ea34736.zip
Due to a bug, the download report only showed the host name instead of the
full url as it used to do prior to version 2.3.2. Fix it applying a patch that was committed upstream. PR: ports/165412 Submitted by: Kryol <kryol@bigmir.net> Feature safe: yes
Diffstat (limited to 'www/sarg')
-rw-r--r--www/sarg/Makefile2
-rw-r--r--www/sarg/files/patch-log.c33
2 files changed, 34 insertions, 1 deletions
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 1ef9bb7151bf..c390fec05bfa 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sarg
PORTVERSION= 2.3.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/www/sarg/files/patch-log.c b/www/sarg/files/patch-log.c
new file mode 100644
index 000000000000..71bc9d805e3b
--- /dev/null
+++ b/www/sarg/files/patch-log.c
@@ -0,0 +1,33 @@
+X-Git-Url: http://sarg.git.sourceforge.net/git/gitweb.cgi?p=sarg%2Fsarg;a=blobdiff_plain;f=log.c;h=a6d6c61014836957c7b5313a282c6d746405c9b9;hp=ed200b3cb8531e5c1cbb78252714d693a6bc9ea3;hb=24eb624ea44bf4c82c602cea2195d85558787b47;hpb=b8523e5ded9d9d80d6330c6d346dc57f5cf147bf
+
+diff --git a/log.c b/log.c
+index ed200b3..a6d6c61 100644
+--- log.c
++++ log.c
+@@ -147,7 +147,7 @@ int main(int argc,char *argv[])
+ unsigned long recs2=0UL;
+ int OutputNonZero = REPORT_EVERY_X_LINES ;
+ bool download_flag=false;
+- char *download_url=NULL;
++ char download_url[MAXLEN];
+ struct getwordstruct gwarea;
+ longline line;
+ time_t tnum;
+@@ -1331,7 +1331,7 @@ int main(int argc,char *argv[])
+ */
+ download_flag=is_download_suffix(full_url);
+ if (download_flag) {
+- download_url=full_url;
++ safe_strcpy(download_url,full_url,sizeof(download_url));
+ download_count++;
+ }
+ } else
+@@ -1503,7 +1503,7 @@ int main(int argc,char *argv[])
+
+ totregsg++;
+
+- if(!dataonly && download_flag && download_url && strstr(code,"DENIED") == 0) {
++ if(!dataonly && download_flag && strstr(code,"DENIED") == 0) {
+ ndownload = 1;
+
+ if ( ! fp_Download_Unsort ) {