aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-08-13 00:48:56 +0800
committermarcus <marcus@FreeBSD.org>2003-08-13 00:48:56 +0800
commit0ae74c772cb0e6e7ba0eb12976b457e21e63c69e (patch)
tree91cb6e414dc501bec72cd2c4dd56258f6fc84e11 /www/seamonkey/Makefile
parent58cc0c897915144d744e76d22a2a7176f3579320 (diff)
downloadfreebsd-ports-gnome-0ae74c772cb0e6e7ba0eb12976b457e21e63c69e.tar.gz
freebsd-ports-gnome-0ae74c772cb0e6e7ba0eb12976b457e21e63c69e.tar.zst
freebsd-ports-gnome-0ae74c772cb0e6e7ba0eb12976b457e21e63c69e.zip
* Add a knob to optionally build XMLTerm [1]
* Add some extra CLI options to the mozilla.sh script [2] * Add a patch to prevent crashes when visiting certain Russian sites [3] * Add a dependency on devel/nspr to avoid problems with Galeon and Epiphany in certain setups [4] PR: 55330 [1] 55412 [2] Submitted by: Alexander Nedotsukov <bland@mail.ru> [1] [2] Sergey Akifyev <asa@gascom.ru> [4] Obtained from: www/mozilla-firebird [3]
Diffstat (limited to 'www/seamonkey/Makefile')
-rw-r--r--www/seamonkey/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index d8ff3407aafa..f69ebd82b7fb 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mozilla
PORTVERSION= 1.5a
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH?= 1
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
@@ -25,7 +25,8 @@ BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ nspr4.1:${PORTSDIR}/devel/nspr
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -110,12 +111,14 @@ CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
.endif
.endif
-
+MOZ_EXTENSIONS= default
.if !defined(WITHOUT_CHATZILLA)
-CONFIGURE_ARGS+= --enable-extensions=default,irc,xmlterm
-.else
-CONFIGURE_ARGS+= --enable-extensions=default,xmlterm
+MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
+.endif
+.if !defined(WITHOUT_XMLTERM)
+MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},xmlterm
.endif
+CONFIGURE_ARGS+= --enable-extensions=${MOZ_EXTENSIONS}
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
.if defined(WITH_JAVASCRIPT_DEBUGGER)
@@ -181,6 +184,7 @@ pre-everything::
@${ECHO_MSG} " WITHOUT_COMPOSER=yes Disables the HTML Composer module"
@${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
@${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
+ @${ECHO_MSG} " WITHOUT_XMLTERM=yes Disable the XMLTerm module"
@${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
@${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS=yes Enable -O2 optimization"
@${ECHO_MSG} ""