aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey/Makefile
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-25 13:15:45 +0800
committerreg <reg@FreeBSD.org>2000-10-25 13:15:45 +0800
commit542025a269d29bddae314ebcc3667b5f8d72bd86 (patch)
tree39a25097ee7c0a4901b560d10e75f996529f328a /www/seamonkey/Makefile
parent7338336f25bcbd9811c15c61f11c87d3a1b49e8d (diff)
downloadfreebsd-ports-gnome-542025a269d29bddae314ebcc3667b5f8d72bd86.tar.gz
freebsd-ports-gnome-542025a269d29bddae314ebcc3667b5f8d72bd86.tar.zst
freebsd-ports-gnome-542025a269d29bddae314ebcc3667b5f8d72bd86.zip
Update to M18. Special thanks Steve Elmer <selmer@netscape.com> and David
Hyatt <hyatt@netscape.com> for pointing me at Bug 51677: http://bugzilla.mozilla.org/show_bug.cgi?id=51677 from where the secret spells were obtained to get the chrome installed properly.
Diffstat (limited to 'www/seamonkey/Makefile')
-rw-r--r--www/seamonkey/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 94c8d6eb8e62..d8f2741b5428 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mozilla
-PORTVERSION= M17
+PORTVERSION= M18
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= mozilla/releases/${PORTVERSION:S/M/m/}/src
@@ -14,24 +14,17 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= reg@FreeBSD.org
-# This port has not been update to M18, because of the requirement of moving
-# to world riteable directories. Until you can fix that, please don't send
-# me patches.
-
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- IDL.2:${PORTSDIR}/devel/ORBit
-
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+LIB_DEPENDS= IDL.2:${PORTSDIR}/devel/ORBit
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
-GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_NEWGCC= yes
+USE_GTK= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= \
--disable-cpp-rtti \
--disable-debug \
@@ -52,8 +45,6 @@ CONFIGURE_ARGS= \
--with-pthreads \
--with-jpeg=${LOCALBASE} \
--with-png=${LOCALBASE}
-CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
- GTK_CONFIG="${GTK_CONFIG}"
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
CC_ONLY_FLAGS="${FLAGS}" CCC_ONLY_FLAGS="${CXXFLAGS}"
@@ -63,6 +54,8 @@ post-build:
@${CHMOD} 555 ${WRKSRC}/mozilla
@(cd ${WRKSRC}/dist/bin; \
${ENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regxpcom; \
+ ${ECHO} skin,install,select,classic/1.0 >> chrome/installed-chrome.txt; \
+ ${ECHO} locale,install,select,en-US >> chrome/installed-chrome.txt; \
${ENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome)
do-install: