aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-02-18 11:50:38 +0800
committeradamw <adamw@FreeBSD.org>2004-02-18 11:50:38 +0800
commitd54a3b0f1a738ab689824d255aa5acf2e0fe3e42 (patch)
treee54f44a172651f143d14bb72b8c2b5ba71f59cdb /www/seamonkey/Makefile
parent85c8f3f941efa685ff55da9ec788c7db82afee6f (diff)
downloadfreebsd-ports-gnome-d54a3b0f1a738ab689824d255aa5acf2e0fe3e42.tar.gz
freebsd-ports-gnome-d54a3b0f1a738ab689824d255aa5acf2e0fe3e42.tar.zst
freebsd-ports-gnome-d54a3b0f1a738ab689824d255aa5acf2e0fe3e42.zip
GTK2 mozilla is now the default, and GTK1 support will be built only if explicitly
requested. This means that mozilla-gtk2 and mozilla-devel-gtk2 are now mozilla and mozilla-devel, respectively; and the old mozilla and mozilla-devel are now mozilla-gtk1 and mozilla-devel-gtk1. This is done for a whole plethora of reasons, and should please everybody except galeon1 fanatics and uhm... anybody else who it doesn't please. If you have WITH_MOZILLA set in your /etc/make.conf, you'll need to update the value accordingly. GTK2 ports will automatically install GTK2 mozilla, and GTK1 ports will automatically install GTK1 ports, so WITH_MOZILLA need be defined only if you want the development version... which are dormant right now anyway. For now, all ports that honoured WITH_MOZILLA=mozilla-{,-devel}-gtk2 will still honour those values as well as WITH_MOZILLA=mozilla{,-devel}, but future ports reserve the right to ignore the *-gtk2 values.
Diffstat (limited to 'www/seamonkey/Makefile')
-rw-r--r--www/seamonkey/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 0db3a4b9eeb2..3ece92d1b925 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -35,11 +35,11 @@ IGNORE= "Main port has been upgraded to 1.6"
MOZILLA?= mozilla-devel
MOZ_SUFX= -devel
-.if defined(WITH_GTK2)
-PKGNAMESUFFIX= -gtk2
-USE_GNOME= gtk20 libidl
-.else
+.if defined(WITH_GTK1)
+PKGNAMESUFFIX= -gtk1
USE_GNOME= gtk12 orbit
+.else
+USE_GNOME= gtk20 libidl
.endif
.if !defined(WITHOUT_XFT)
@@ -140,10 +140,10 @@ CONFIGURE_ARGS+= --enable-calendar
CONFIGURE_ARGS+= --disable-composer
.endif
-.if defined(WITH_GTK2)
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
-.else
+.if defined(WITH_GTK1)
CONFIGURE_ARGS+= --enable-default-toolkit=gtk
+.else
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
.endif
.if !defined(WITHOUT_XFT)