aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2004-12-11 10:11:23 +0800
committerahze <ahze@FreeBSD.org>2004-12-11 10:11:23 +0800
commit8425079e49d4868610285e4c5978780d60668cc2 (patch)
treeae16c73d8b8deb9659dc0960a66fddbe8c964278 /www/seamonkey
parente852908b9fef4921606174105fe01fe7ed5de423 (diff)
downloadfreebsd-ports-gnome-8425079e49d4868610285e4c5978780d60668cc2.tar.gz
freebsd-ports-gnome-8425079e49d4868610285e4c5978780d60668cc2.tar.zst
freebsd-ports-gnome-8425079e49d4868610285e4c5978780d60668cc2.zip
- Fix plist in firefox [1]
- Touch lib/browser_plugins/.${PORTNAME}.keep so this directory will not be removed durring deinstall of mozilla[-devel] or firefox if you still have mozilla[-devel] or firefox installed. Pointed out by: pointy hat [1]
Diffstat (limited to 'www/seamonkey')
-rw-r--r--www/seamonkey/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 97ad72c77fd3..cb1eeec7f61a 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mozilla
PORTVERSION= 1.8.a5
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH?= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -293,8 +293,9 @@ pre-install:
break; \
fi; \
done; \
- ${ECHO_CMD} @dirrm lib/browser_plugins >> ${PLIST} ; \
fi
+ ${ECHO_CMD} lib/browser_plugins/.${PORTNAME}.keep >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${RMDIR} %D/lib/browser_plugins 2>/dev/null || ${TRUE}" >> ${PLIST}
${ECHO_CMD} lib/${MOZILLA}/mozilla >> ${PLIST}
${ECHO_CMD} lib/${MOZILLA}/mozilla-config >> ${PLIST}
.if !defined(WITHOUT_MAILNEWS)
@@ -328,6 +329,7 @@ do-install:
if [ ! -d ${PREFIX}/lib/browser_plugins ]; then \
${MKDIR} ${PREFIX}/lib/browser_plugins ; \
fi
+ ${TOUCH} -f ${PREFIX}/lib/browser_plugins/.${PORTNAME}.keep
if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
for jpi in ${JPI_LIST}; do \
if [ -f $${jpi} ]; then \