aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-07-07 07:11:56 +0800
committeradamw <adamw@FreeBSD.org>2004-07-07 07:11:56 +0800
commitdad825f9e7473d8fc83a731a53a3f310fcf86014 (patch)
tree2de7a7c4167085b2a7159271bd90df81144fe668 /www/seamonkey
parent5d1dd3e80d047f289bda9a7d739095121ffa91fe (diff)
downloadfreebsd-ports-gnome-dad825f9e7473d8fc83a731a53a3f310fcf86014.tar.gz
freebsd-ports-gnome-dad825f9e7473d8fc83a731a53a3f310fcf86014.tar.zst
freebsd-ports-gnome-dad825f9e7473d8fc83a731a53a3f310fcf86014.zip
Update to 1.8alpha1.
Use a pkg-install to register chrome stuff.
Diffstat (limited to 'www/seamonkey')
-rw-r--r--www/seamonkey/Makefile18
-rw-r--r--www/seamonkey/distinfo4
-rw-r--r--www/seamonkey/files/patch-extensions_negotiateauth_Makefile.in17
-rw-r--r--www/seamonkey/files/patch-nsprpub-pr-src-io-prprf.c14
-rw-r--r--www/seamonkey/files/patch-qt22
-rw-r--r--www/seamonkey/pkg-descr.gtk112
-rw-r--r--www/seamonkey/pkg-install.in29
7 files changed, 63 insertions, 53 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 6fc9e43e214c..ce282e7d841a 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME?= mozilla
-PORTVERSION= 1.7.r3
+PORTVERSION= 1.8.a1
PORTREVISION?= 0
PORTEPOCH?= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
${MASTER_SITE_LOCAL:S/$/:local/}
-MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.r3/rc3/}/src \
+MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.a1/a1/}/src \
marcus/:local
-DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.r3/rc3/}${EXTRACT_SUFX}
+DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.a1/a1/}${EXTRACT_SUFX}
MAINTAINER= gnome@FreeBSD.org
COMMENT= The open source, standards compliant web browser
@@ -29,8 +29,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
WRKSRC= ${WRKDIR}/${PORTNAME}
-IGNORE= "Out-of-date, use www/mozilla instead for now"
-
MOZILLA?= mozilla-devel
MOZ_SUFX?= -devel
@@ -83,6 +81,7 @@ PLIST= ${WRKDIR}/pkg-plist
MOZ_EXTENSIONS= default
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1 \
LOCALBASE=${LOCALBASE}
+PKGINSTALL= ${WRKDIR}/pkg-install
CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
@@ -251,6 +250,8 @@ post-patch:
s|mozilla-nspr|mozilla-nspr${MOZ_SUFX}${PKGNAMESUFFIX}|g' \
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
+ @${SED} -e 's|%%MOZDIR%%|${PREFIX}/lib/${MOZILLA}|g' \
+ < ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
pre-configure:
@if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
@@ -261,10 +262,6 @@ pre-configure:
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}
- (cd ${WRKSRC}/dist/bin; \
- ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regxpcom; \
- ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome; \
- ${TOUCH} ./chrome/user-skins.rdf ./chrome/user-locales.rdf)
${FIND} ${WRKSRC}/dist/bin -type d | ${SORT} -r | \
${XARGS} ${RMDIR} 2> /dev/null || ${TRUE}
@@ -331,6 +328,9 @@ do-install:
post-install:
@${CHMOD} -R u-w ${PREFIX}/lib/${MOZILLA}/components
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/seamonkey/distinfo b/www/seamonkey/distinfo
index de13ec0e78d3..e5f3563c699c 100644
--- a/www/seamonkey/distinfo
+++ b/www/seamonkey/distinfo
@@ -1,2 +1,2 @@
-MD5 (mozilla-source-1.7rc3.tar.bz2) = 8dfee28c027db903aab8f826ee594f75
-SIZE (mozilla-source-1.7rc3.tar.bz2) = 35170922
+MD5 (mozilla-source-1.8a1.tar.bz2) = 5ba8b7d5d581fc407f33857dd8d3756e
+SIZE (mozilla-source-1.8a1.tar.bz2) = 33798635
diff --git a/www/seamonkey/files/patch-extensions_negotiateauth_Makefile.in b/www/seamonkey/files/patch-extensions_negotiateauth_Makefile.in
index ca1f969ce5fe..d2241dbfe9f6 100644
--- a/www/seamonkey/files/patch-extensions_negotiateauth_Makefile.in
+++ b/www/seamonkey/files/patch-extensions_negotiateauth_Makefile.in
@@ -1,12 +1,19 @@
---- extensions/negotiateauth/Makefile.in.orig Tue Apr 13 12:19:44 2004
-+++ extensions/negotiateauth/Makefile.in Tue Apr 13 12:19:53 2004
-@@ -68,8 +68,8 @@
+--- extensions/negotiateauth/Makefile.in.orig Wed Apr 28 03:26:19 2004
++++ extensions/negotiateauth/Makefile.in Tue Jul 6 16:27:07 2004
+@@ -66,7 +66,6 @@
$(NULL)
EXTRA_DSO_LDOPTS = \
- $(MOZ_COMPONENT_LIBS) \
- $(GSSAPI_LIBS) \
-+ $(MOZ_COMPONENT_LIBS) \
$(NULL)
+ ifneq (,$(GSSAPI_LIBS))
+@@ -74,6 +73,8 @@
+ EXTRA_DSO_LDOPTS += $(GSSAPI_LIBS)
+ CPPSRCS += nsNegotiateAuthGSSAPI.cpp
+ endif
++
++EXTRA_DSO_LDOPTS += $(MOZ_COMPONENT_LIBS)
+
# make sure this component is never statically linked into the main
+ # application. this is necessary since we don't want to force users
diff --git a/www/seamonkey/files/patch-nsprpub-pr-src-io-prprf.c b/www/seamonkey/files/patch-nsprpub-pr-src-io-prprf.c
deleted file mode 100644
index f9949d6d9c96..000000000000
--- a/www/seamonkey/files/patch-nsprpub-pr-src-io-prprf.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- nsprpub/pr/src/io/prprf.c.orig Mon Mar 8 22:18:19 2004
-+++ nsprpub/pr/src/io/prprf.c Fri Mar 19 15:26:55 2004
-@@ -51,7 +51,10 @@
- ** Note: on some platforms va_list is defined as an array,
- ** and requires array notation.
- */
--#if (defined(LINUX) && defined(__x86_64__))
-+#if defined(__amd64__)
-+#include <stdarg.h>
-+#define VARARGS_ASSIGN(foo, bar) va_copy((foo), (bar))
-+#elif (defined(LINUX) && defined(__x86_64__))
- #define VARARGS_ASSIGN(foo, bar) __va_copy((foo), (bar))
- #elif (defined(LINUX) && defined(__powerpc__)) || \
- (defined(LINUX) && defined(__s390__)) || \
diff --git a/www/seamonkey/files/patch-qt b/www/seamonkey/files/patch-qt
index 6b72f3f007ae..8b6b84543152 100644
--- a/www/seamonkey/files/patch-qt
+++ b/www/seamonkey/files/patch-qt
@@ -1,15 +1,15 @@
---- configure.orig Tue Apr 20 21:39:17 2004
-+++ configure Thu Apr 29 14:01:52 2004
-@@ -9362,7 +9362,7 @@
+--- configure.orig Wed May 19 14:22:51 2004
++++ configure Tue Jul 6 16:45:02 2004
+@@ -9366,7 +9366,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-liconv $LIBS"
+LIBS="-L$LOCALBASE/lib -liconv $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 9368 "configure"
+ #line 9372 "configure"
#include "confdefs.h"
-@@ -9393,7 +9393,7 @@
+@@ -9397,7 +9397,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
@@ -18,16 +18,16 @@
else
echo "$ac_t""no" 1>&6
echo $ac_n "checking for libiconv in -liconv""... $ac_c" 1>&6
-@@ -9403,7 +9403,7 @@
+@@ -9407,7 +9407,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-liconv $LIBS"
+LIBS="-L$LOCALBASE/lib -liconv $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 9409 "configure"
+ #line 9413 "configure"
#include "confdefs.h"
-@@ -9434,7 +9434,7 @@
+@@ -9438,7 +9438,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
@@ -36,15 +36,15 @@
else
echo "$ac_t""no" 1>&6
fi
-@@ -12298,9 +12298,9 @@
+@@ -12467,9 +12467,9 @@
-MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector irc universalchardet typeaheadfind webservices spellcheck gnomevfs negotiateauth"
+MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector universalchardet typeaheadfind webservices spellcheck gnomevfs negotiateauth"
--MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT xmlterm datetime finger cview layout-debug tasks"
-+MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT irc xmlterm datetime finger cview layout-debug tasks"
+-MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT xmlterm datetime finger cview layout-debug tasks sql"
++MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT irc xmlterm datetime finger cview layout-debug tasks sql"
# Check whether --enable-extensions or --disable-extensions was given.
if test "${enable_extensions+set}" = set; then
diff --git a/www/seamonkey/pkg-descr.gtk1 b/www/seamonkey/pkg-descr.gtk1
deleted file mode 100644
index ba0062b77d01..000000000000
--- a/www/seamonkey/pkg-descr.gtk1
+++ /dev/null
@@ -1,12 +0,0 @@
-This is the current release of the Mozilla open source web browser. It should
-be fully compliant with all W3C standards, including HTML, CSS, XML, XSL,
-JavaScript, MathML, SVG and RDF. This version also supports SSL encryption,
-and Java with the use of the FreeBSD native Java plug-in.
-
-This is the latest bleeding edge release. Beware that you'll probably find
-bugs here, so if you value stability, try www/mozilla or www/mozilla-vendor.
-
-This version has been built with GTK+-1 bindings for use with older
-applications such as Galeon 1.
-
-WWW: http://www.mozilla.org/
diff --git a/www/seamonkey/pkg-install.in b/www/seamonkey/pkg-install.in
new file mode 100644
index 000000000000..3687532f1882
--- /dev/null
+++ b/www/seamonkey/pkg-install.in
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Date created: Mon Nov 29, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+# Fix the chrome registry.
+
+umask 022
+PATH=/bin:/usr/bin
+
+[ "x$1" = "x" ] && exit 1
+[ "x$2" != "xPOST-INSTALL" ] && exit 0
+
+MOZDIR=%%MOZDIR%%
+REGXPCOM=${MOZDIR}/regxpcom
+REGCHROME=${MOZDIR}/regchrome
+
+echo "===> Building Chrome's registry..."
+rm -rf ${MOZDIR}/chrome/overlayinfo
+rm -f ${MOZDIR}/chrome/*.rdf
+mkdir -p ${MOZDIR}/chrome/overlayinfo
+rm -f ${MOZDIR}/component.reg
+
+cd ${MOZDIR} || exit 1
+./run-mozilla.sh ${REGXPCOM} || true
+./run-mozilla.sh ${REGCHROME} || true
+
+exit 0