aboutsummaryrefslogtreecommitdiffstats
path: root/www/serf
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-02-27 04:59:23 +0800
committerOlli Hauer <ohauer@FreeBSD.org>2014-02-27 04:59:23 +0800
commit218bce8643dc3887e9ba4d585786ca92f9777384 (patch)
tree26c7bf59ba5b81d93e1338b1adebd65f30f775af /www/serf
parent198d28f96c3d66b56c8bb93c27304bd27be6a49e (diff)
downloadfreebsd-ports-gnome-218bce8643dc3887e9ba4d585786ca92f9777384.tar.gz
freebsd-ports-gnome-218bce8643dc3887e9ba4d585786ca92f9777384.tar.zst
freebsd-ports-gnome-218bce8643dc3887e9ba4d585786ca92f9777384.zip
- update to version 1.3.4
- do not use USES=scons [1] - adjust MASTER_SITES - adopt new LIB_DEPENDS notation [1] The upstream Scons script is terrible broken, the ports framework sets args unknown to the SConstruct script and every unknown arg breaks the script :( Unluckily I haven't found a way to strip the breaking args with our shiny USES=scons framework) Changes: Serf 1.3.4 [2014-02-08, from /tags/1.3.4, rxxxx] Fix issue #119: Endless loop during ssl tunnel setup with Negotiate authn Fix issue #123: Can't setup ssl tunnel which sends Connection close header Fix a race condition when initializing OpenSSL from multiple threads (r2263) Fix issue #138: Incorrect pkg-config file when GSSAPI isn't configured
Diffstat (limited to 'www/serf')
-rw-r--r--www/serf/Makefile6
-rw-r--r--www/serf/distinfo4
-rw-r--r--www/serf/files/patch-SConstruct16
3 files changed, 12 insertions, 14 deletions
diff --git a/www/serf/Makefile b/www/serf/Makefile
index e89dcd7e664e..f8caf5a43f83 100644
--- a/www/serf/Makefile
+++ b/www/serf/Makefile
@@ -2,16 +2,16 @@
# $FreeBSD$
PORTNAME= serf
-PORTVERSION= 1.3.3
+PORTVERSION= 1.3.4
CATEGORIES= www
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= http://serf.googlecode.com/svn/src_releases/
MAINTAINER= apache@FreeBSD.org
COMMENT= Serf HTTP client library
LICENSE= APACHE20
-LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr1
+LIB_DEPENDS+= libapr-1.so:${PORTSDIR}/devel/apr1
USE_SCONS= yes
USE_BZIP2= yes
diff --git a/www/serf/distinfo b/www/serf/distinfo
index 35112c5cec8d..7cb7af507951 100644
--- a/www/serf/distinfo
+++ b/www/serf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (serf-1.3.3.tar.bz2) = 02eae04176296347be3c32b0da8d8610064f4a9f40065fb1cefbe5b656f8ad2b
-SIZE (serf-1.3.3.tar.bz2) = 140213
+SHA256 (serf-1.3.4.tar.bz2) = db5dcf68be722156de67518231da17c451f6c5d16523ff03e4e37f28d06ee0cb
+SIZE (serf-1.3.4.tar.bz2) = 140680
diff --git a/www/serf/files/patch-SConstruct b/www/serf/files/patch-SConstruct
index 3f1ec54f9491..4dca9655a766 100644
--- a/www/serf/files/patch-SConstruct
+++ b/www/serf/files/patch-SConstruct
@@ -1,5 +1,5 @@
---- ./SConstruct.orig 2013-10-04 17:11:04.000000000 +0200
-+++ ./SConstruct 2013-10-05 16:16:20.000000000 +0200
+--- ./SConstruct.orig 2014-02-04 21:11:10.000000000 +0100
++++ ./SConstruct 2014-02-26 21:55:54.000000000 +0100
@@ -69,6 +69,9 @@
opts = Variables(files=[SAVED_CONFIG])
@@ -18,17 +18,15 @@
# This version string is used in the dynamic library name, and for Mac OS X also
# for the current_version and compatibility_version options in the .dylib
-@@ -385,7 +389,9 @@
- env.get('GSSAPI_LIBS')),
- })
+@@ -387,6 +391,8 @@
--env.Default(lib_static, lib_shared, pkgconfig)
-+env.Default(lib_static, lib_shared, pkgconfig )
-+
-+#print env.Dump()
+ env.Default(lib_static, lib_shared, pkgconfig)
++#print env.Dump()
++
if CALLOUT_OKAY:
conf = Configure(env)
+
@@ -418,7 +424,7 @@
env.Alias('install-lib', [install_static, install_shared,
])