aboutsummaryrefslogtreecommitdiffstats
path: root/www/serf
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-11-10 04:21:36 +0800
committerOlli Hauer <ohauer@FreeBSD.org>2013-11-10 04:21:36 +0800
commitc4fb8b8dc17baef6cc9c943cc5d2b62b96e06ff6 (patch)
tree0c3414a65dc38a0c813ff98ae6a76f2b79253fb0 /www/serf
parenta11d4de96f127f23321060d75c653d61fd28f955 (diff)
downloadfreebsd-ports-gnome-c4fb8b8dc17baef6cc9c943cc5d2b62b96e06ff6.tar.gz
freebsd-ports-gnome-c4fb8b8dc17baef6cc9c943cc5d2b62b96e06ff6.tar.zst
freebsd-ports-gnome-c4fb8b8dc17baef6cc9c943cc5d2b62b96e06ff6.zip
- add Apache2 license
- unbreak devel/subversion-static and devel/subversion (with STATIC=on) by installing a absolute minimum libserf-1.la file - bump PORTREVISION
Diffstat (limited to 'www/serf')
-rw-r--r--www/serf/Makefile6
-rw-r--r--www/serf/files/libserf-1.la.in41
-rw-r--r--www/serf/pkg-plist1
3 files changed, 48 insertions, 0 deletions
diff --git a/www/serf/Makefile b/www/serf/Makefile
index d1c57bd6d1c1..6d5cbf551d24 100644
--- a/www/serf/Makefile
+++ b/www/serf/Makefile
@@ -3,12 +3,15 @@
PORTNAME= serf
PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= GOOGLE_CODE
MAINTAINER= apache@FreeBSD.org
COMMENT= Serf HTTP client library
+LICENSE= AL2
+
LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr1
USE_SCONS= yes
@@ -16,6 +19,8 @@ USE_BZIP2= yes
USE_OPENSSL= yes
USE_LDCONFIG= yes
+SUB_FILES= libserf-1.la
+
OPTIONS_DEFINE= DOCS
SCONS_ENV= # empty
@@ -34,6 +39,7 @@ post-patch:
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/design-guide.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${SUB_FILES:S|^|${WRKDIR}/|} ${STAGEDIR}${PREFIX}/lib
regression-test check: build
@(cd ${WRKSRC} && ${SCONS_BIN} check)
diff --git a/www/serf/files/libserf-1.la.in b/www/serf/files/libserf-1.la.in
new file mode 100644
index 000000000000..84f3797504c6
--- /dev/null
+++ b/www/serf/files/libserf-1.la.in
@@ -0,0 +1,41 @@
+# libserf-1.la - a libtool library file
+# Generated by libtool (GNU libtool) 2.4.2
+#
+# Please DO NOT delete this file!
+# It is necessary for linking the library.
+
+# The name that we can dlopen(3).
+dlname='libserf-1.so'
+
+# Names of this library.
+library_names='libserf-1.so'
+
+# The name of the static archive.
+old_library='libserf-1.a'
+
+# Linker flags that can not go in dependency_libs.
+inherited_linker_flags=' -pthread'
+
+# Libraries that this one depends upon.
+dependency_libs=' -R%%LOCALBASE%%/lib -L/usr/lib -L%%LOCALBASE%%/lib %%LOCALBASE%%/lib/libaprutil-1.la %%LOCALBASE%%/lib/libapr-1.la -lcrypt -lz -lssl -lcrypto'
+
+# Names of additional weak libraries provided by this library
+weak_library_names=''
+
+# Version information for libserf-1.
+current=0
+age=0
+revision=0
+
+# Is this an already installed library?
+installed=yes
+
+# Should we warn about portability when linking against -modules?
+shouldnotlink=no
+
+# Files to dlopen/dlpreopen
+dlopen=''
+dlpreopen=''
+
+# Directory that this library needs to be installed in:
+libdir='%%LOCALBASE%%/lib'
diff --git a/www/serf/pkg-plist b/www/serf/pkg-plist
index 36775eb22698..1c464dc22fdb 100644
--- a/www/serf/pkg-plist
+++ b/www/serf/pkg-plist
@@ -2,6 +2,7 @@ include/serf-1/serf.h
include/serf-1/serf_bucket_types.h
include/serf-1/serf_bucket_util.h
lib/libserf-1.a
+lib/libserf-1.la
lib/libserf-1.so
lib/libserf-1.so.1
lib/libserf-1.so.1.3.0