aboutsummaryrefslogtreecommitdiffstats
path: root/www/simplog/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-07-18 20:22:49 +0800
committeredwin <edwin@FreeBSD.org>2004-07-18 20:22:49 +0800
commitdd2f01446263320ad6763403e5c9552daafbe865 (patch)
treea7c21e49ddd8ec8666e989bd06bf7d18fdf36880 /www/simplog/Makefile
parente9e091266f7c7ee7502087281e7f2166a658cd62 (diff)
downloadfreebsd-ports-gnome-dd2f01446263320ad6763403e5c9552daafbe865.tar.gz
freebsd-ports-gnome-dd2f01446263320ad6763403e5c9552daafbe865.tar.zst
freebsd-ports-gnome-dd2f01446263320ad6763403e5c9552daafbe865.zip
New port: www/simplog: A simple php weblog
Simplog was created to provide people with an easy way to create and maintain their own personal or a community weblog. With the increasing number of people creating on-line journals, there is a need for a tool that allows them a quick and easy way to share their lives with the rest of the world. Simplog is NOT trying to a news/portal app like Slash/Scoop/PHP-Nuke, nor will it ever be, although it can be used for this purpose. Simplog is intended for use as a personal or community weblog tool. PR: ports/65770 Submitted by: Jose Liang <jose@jose.idv.tw>
Diffstat (limited to 'www/simplog/Makefile')
-rw-r--r--www/simplog/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/www/simplog/Makefile b/www/simplog/Makefile
new file mode 100644
index 000000000000..03cc578d2e80
--- /dev/null
+++ b/www/simplog/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: simplog
+# Date created: 19 April 2004, 21:40 +08:00 (CST)
+# Whom: Jose Liang <jose@jose.idv.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= simplog
+PORTVERSION= 0.9
+CATEGORIES= www
+MASTER_SITES= ftp://jose.idv.tw/simplog/
+
+MAINTAINER= jose@jose.idv.tw
+COMMENT= A complete and powerful blogging tool
+
+DATADIR= ${PREFIX}/www/simplog
+NO_BUILD= yes
+USE_APACHE= yes
+USE_PHP= yes
+
+WRKSRC?= ${WRKDIR}/simplog
+
+do-install:
+ @${ECHO} " "
+ @${ECHO} "**************************"
+ @${ECHO} "*** Installing simplog ***"
+ @${ECHO} "**************************"
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${CP} -R templates install images doc cache adodb * \
+ ${DATADIR}
+
+post-install:
+ @${ECHO} " "
+ @${ECHO} "*************************"
+ @${ECHO} "**** Congratulations ****"
+ @${ECHO} "*************************"
+ @${ECHO} "The installation of simplog is complete, please check\
+ README in ${DATADIR} first."
+ @${ECHO} "For more informations, documentation is available at\
+ ${DATADIR}/doc/index.php."
+
+.include <bsd.port.mk>