aboutsummaryrefslogtreecommitdiffstats
path: root/www/sqstat
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-05-05 01:31:47 +0800
committersem <sem@FreeBSD.org>2006-05-05 01:31:47 +0800
commit17a04394c739171909f0be2a8ec39a5f13befa3b (patch)
treea4c7e8e979ecbbe793503ba7a78c0f2bfd021097 /www/sqstat
parentaa161866534d442845b06b1830b85855dc7029b2 (diff)
downloadfreebsd-ports-gnome-17a04394c739171909f0be2a8ec39a5f13befa3b.tar.gz
freebsd-ports-gnome-17a04394c739171909f0be2a8ec39a5f13befa3b.tar.zst
freebsd-ports-gnome-17a04394c739171909f0be2a8ec39a5f13befa3b.zip
SqStat is a script which allows to look through active squid users
connections. It use cachemgr protocol to get information from squid proxy server. WWW: http://samm.kiev.ua/sqstat/
Diffstat (limited to 'www/sqstat')
-rw-r--r--www/sqstat/Makefile45
-rw-r--r--www/sqstat/distinfo3
-rw-r--r--www/sqstat/files/pkg-message.in17
-rw-r--r--www/sqstat/pkg-descr5
4 files changed, 70 insertions, 0 deletions
diff --git a/www/sqstat/Makefile b/www/sqstat/Makefile
new file mode 100644
index 000000000000..a5ce99475350
--- /dev/null
+++ b/www/sqstat/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: sqstat
+# Date created: 4 May 2006
+# Whom: Sergey Matveychuk <sem@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqstat
+PORTVERSION= 0.9.5
+CATEGORIES= www
+MASTER_SITES= http://samm.kiev.ua/sqstat/
+
+MAINTAINER= sem@FreeBSD.org
+COMMENT= A script which allows to look through active squid users connections
+
+USE_PHP= pcre
+NO_BUILD= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+SQSTATDIR?= share/${PORTNAME}
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_LIST= SQSTATDIR=${SQSTATDIR}
+
+PLIST_DIRS= ${SQSTATDIR}
+PLIST_FILES= ${SQSTATDIR}/sqstat.css ${SQSTATDIR}/sqstat.php
+PORTDOCS= CHANGES LICENSE README TODO
+
+do-install:
+ @${MKDIR} ${PREFIX}/${SQSTATDIR}; \
+ for f in ${PLIST_FILES}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$${f##*/} ${PREFIX}/${SQSTATDIR}; \
+ done
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}; \
+ for f in ${PORTDOCS}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
+ done
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/sqstat/distinfo b/www/sqstat/distinfo
new file mode 100644
index 000000000000..be2ee101f0ea
--- /dev/null
+++ b/www/sqstat/distinfo
@@ -0,0 +1,3 @@
+MD5 (sqstat-0.9.5.tar.gz) = fe6ee9b65afb33dd32b51a4e682bf16e
+SHA256 (sqstat-0.9.5.tar.gz) = 6bc3f0efe1ad1faf11e2206789058a3b532b6ac8cebea09188f689a2761da3e1
+SIZE (sqstat-0.9.5.tar.gz) = 4901
diff --git a/www/sqstat/files/pkg-message.in b/www/sqstat/files/pkg-message.in
new file mode 100644
index 000000000000..00c1f3db3e90
--- /dev/null
+++ b/www/sqstat/files/pkg-message.in
@@ -0,0 +1,17 @@
+======================================================================
+- Edit %%PREFIX%%/%%SQSTATDIR%%/sqstat.php file:
+
+set $squidhost, $squidport, $cachemgr_passwd, $resolveip as you like.
+
+- Set up squid:
+
+acl manager proto cache_object
+# replace 10.0.0.1 with your webserver IP
+acl webserver src 10.0.0.1/255.255.255.255
+http_access allow manager webserver
+http_access deny manager
+
+- Set up apache web server:
+
+Alias /sqstat "%%PREFIX%%/%%SQSTATDIR%%/"
+======================================================================
diff --git a/www/sqstat/pkg-descr b/www/sqstat/pkg-descr
new file mode 100644
index 000000000000..0eee6f6071f4
--- /dev/null
+++ b/www/sqstat/pkg-descr
@@ -0,0 +1,5 @@
+SqStat is a script which allows to look through active squid users
+connections. It use cachemgr protocol to get information from
+squid proxy server.
+
+WWW: http://samm.kiev.ua/sqstat/