aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid27/pkg-deinstall
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-01-17 05:18:20 +0800
committersergei <sergei@FreeBSD.org>2004-01-17 05:18:20 +0800
commitb2bcb30c41f8b21180777a739f59421b821ebb0c (patch)
treee24e872aae3fd491fa10a084b897b2ae87f7d3d2 /www/squid27/pkg-deinstall
parent6329d4de5eb4a033e211f4530ac24f65e0dd7905 (diff)
downloadfreebsd-ports-gnome-b2bcb30c41f8b21180777a739f59421b821ebb0c.tar.gz
freebsd-ports-gnome-b2bcb30c41f8b21180777a739f59421b821ebb0c.tar.zst
freebsd-ports-gnome-b2bcb30c41f8b21180777a739f59421b821ebb0c.zip
- configure squid to run under a dedicated "squid" user by default; make use
of SQUID_{UID,GID} which other squid-related ports already implemented. The user/group will be created on the fly if they do not already exist. - introduce WITH_SQUID_LDAP_AUTH to pull in the necessary bits to compile and use the ldap_auth helper - install some more authentication helper applications by default - install helper applications to ${PREFIX}/libexec/squid instead of ${PREFIX}/libexec, add notes about it in pkg-install and pkg-descr - cleanup the pre-installation tasks and move them from Makefile and pkg-plist into the pkg-install script; make 'make install' and 'pkg_add' actually do the same thing - introduce a pkg-deinstall script - make squid.sh rcNG compatible (when either /etc/rc_subr or ${PREFIX}/etc/rc_subr is present, the first one will be used, otherwise the script will work as a "rc classic" script so no additional dependency on the rc_subr port should be needed) - some Makefile cleanups: + the squid installation procedure now correctly strips binaries, so there is no need to do this manually anymore + generate those parts of pkg-plist dynamically that may be affected by user set tunables (currently the localized error pages and helper applications) + document the available configuration options in a slightly different style + remove some obsolete variable declarations and comments + honor NOPORTDOCS - add CONFLICTS - add another vendor patch, see http://www.squid-cache.org/bugs/show_bug.cgi?id=890 for a thorough explanation of what has been fixed. - since we can no longer take the presence of Lithuanian error pages for granted, wrap the workaround for the errorpages.patch with '.if exists()' - bump PORTREVISION PR: 61315 Submitted by: maintainer
Diffstat (limited to 'www/squid27/pkg-deinstall')
-rw-r--r--www/squid27/pkg-deinstall29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/squid27/pkg-deinstall b/www/squid27/pkg-deinstall
new file mode 100644
index 000000000000..3a95b4f50e0d
--- /dev/null
+++ b/www/squid27/pkg-deinstall
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/bin:/usr/bin:/usr/sbin
+pkgname=$1
+
+case $2 in
+DEINSTALL)
+ ;;
+POST-DEINSTALL)
+ echo "===> post-deinstallation information for ${pkgname}"
+ echo ""
+ echo " Please note that ${pkgname} was not completely removed"
+ echo " from this system."
+ echo ""
+ echo " The cache and log directories, squid's user account,"
+ echo " and any modified configuration files have been preserved"
+ echo " in case you want to install an updated version of squid"
+ echo " on this system. You must remove them manually if you do"
+ echo " not want to use squid any longer."
+ echo ""
+ ;;
+*)
+ exit 64
+ ;;
+esac
+exit 0