aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid27
diff options
context:
space:
mode:
authorpeter <peter@FreeBSD.org>1998-01-21 11:06:06 +0800
committerpeter <peter@FreeBSD.org>1998-01-21 11:06:06 +0800
commit10d490e58175d7b66938e0b3048932410a62619f (patch)
treedcd1f49c892820ee5b39693406c5c7f656c997f6 /www/squid27
parent56d198a1020be8ec023a5124c337138839b95384 (diff)
downloadfreebsd-ports-gnome-10d490e58175d7b66938e0b3048932410a62619f.tar.gz
freebsd-ports-gnome-10d490e58175d7b66938e0b3048932410a62619f.tar.zst
freebsd-ports-gnome-10d490e58175d7b66938e0b3048932410a62619f.zip
Update this for the benefit of the new broken patch. Tell it to look at
Index: like posix says, rather than going into dummy mode. The distributed patches are generated with standard cvs and don't have ache's hack (which doesn't work when new files are added anyway).
Diffstat (limited to 'www/squid27')
-rw-r--r--www/squid27/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/www/squid27/Makefile b/www/squid27/Makefile
index e8c28dc48a87..72cf8b539caa 100644
--- a/www/squid27/Makefile
+++ b/www/squid27/Makefile
@@ -3,7 +3,7 @@
# Date created: Thu Nov 7 00:53:18 WST 1996
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.36 1998/01/04 09:30:18 peter Exp $
+# $Id: Makefile,v 1.37 1998/01/10 14:38:23 peter Exp $
#
DISTNAME= squid-1.2.beta11
@@ -16,6 +16,9 @@ MASTER_SITES= \
ftp://ftp.net.lut.ac.uk/squid/squid-1.2.beta/
EXTRACT_SUFX= -src.tar.gz
+# Note, these are generated with CVS and the new patch does not correctly
+# apply them, so we have to force the new patch into better POSIX compliant
+# mode. See end of Makefile. See also post-extract.
PATCH_SITES+= http://squid.nlanr.net/Squid/1.2.beta/
PATCHFILES+= 1.2.beta11.patches
@@ -64,6 +67,9 @@ MAKEFILE= makefile
# - Show malloc statistics in cachemgr status pages
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
+# For the benefit of the new broken patch.
+post-extract:
+ touch ${WRKSRC}/lib/malloc-2.6.4.c
post-install:
cd ${WRKSRC}/src; make install-pinger
@@ -84,3 +90,6 @@ post-install:
fi
.include <bsd.port.mk>
+
+# Stupid GNU Make 2.5!!!
+PATCH:= env POSIXLY_CORRECT=yes ${PATCH}