aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid27
diff options
context:
space:
mode:
authoradrian <adrian@FreeBSD.org>2001-09-01 16:34:14 +0800
committeradrian <adrian@FreeBSD.org>2001-09-01 16:34:14 +0800
commit379bc2f0ba58ade44655eea99518805d122cec58 (patch)
treed98ef8986de5a1e1eafd8a6ebe19092de4b6e81d /www/squid27
parent07ccf980718b403dd5b6ef9da8a22c861aa01bff (diff)
downloadfreebsd-ports-gnome-379bc2f0ba58ade44655eea99518805d122cec58.tar.gz
freebsd-ports-gnome-379bc2f0ba58ade44655eea99518805d122cec58.tar.zst
freebsd-ports-gnome-379bc2f0ba58ade44655eea99518805d122cec58.zip
Remove the RunCache stuff and let squid handle its own child maintainence.
This now means that 'stop' as an argument works correctly, and doesn't end up having squid restarted. I've added some sleep code to wait for squid to complete its shutdown, but I have commented it out for the time being as I don't know whether its good practice to have your machine sleep during shutdown. I'll research it some more. :)
Diffstat (limited to 'www/squid27')
-rw-r--r--www/squid27/Makefile2
-rw-r--r--www/squid27/files/squid.sh9
2 files changed, 8 insertions, 3 deletions
diff --git a/www/squid27/Makefile b/www/squid27/Makefile
index 150ea88cb47a..1d578451efdf 100644
--- a/www/squid27/Makefile
+++ b/www/squid27/Makefile
@@ -7,7 +7,7 @@
PORTNAME= squid
PORTVERSION= 2.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/squid-2/STABLE/ \
diff --git a/www/squid27/files/squid.sh b/www/squid27/files/squid.sh
index e9a3144e8c93..40f655b04f27 100644
--- a/www/squid27/files/squid.sh
+++ b/www/squid27/files/squid.sh
@@ -7,11 +7,16 @@ fi
case "$1" in
start)
- if [ -x ${PREFIX}/sbin/RunCache -a -f ${PREFIX}/etc/squid/squid.conf ]; then
- (cd /tmp; ${PREFIX}/sbin/RunCache >/dev/null 2>&1 &) ; echo -n ' squid'
+ if [ -x ${PREFIX}/sbin/squid -a -f ${PREFIX}/etc/squid/squid.conf ]; then
+ (cd /${PREFIX}/squid/logs; ${PREFIX}/sbin/squid >/dev/null 2>&1 &) ; echo -n ' squid'
fi
;;
stop)
+ ${PREFIX}/sbin/squid -k shutdown 2>&1
+ # Uncomment this if you'd like the system to (attempt to
+ # wait for) squid to shut down cleanly
+ #echo "Sleeping for 45 seconds to allow squid to shutdown.."
+ #sleep 45
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2