aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid30/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-06-10 23:40:44 +0800
committerkrion <krion@FreeBSD.org>2004-06-10 23:40:44 +0800
commit42bad3fe54c824e861223ef1efa16fee85bd1e94 (patch)
treefd4840126f5ccc25b7217724ea8a978eb4d89216 /www/squid30/Makefile
parent52cacacfecf16f635e4a07d5ad01a1410ec152f2 (diff)
downloadfreebsd-ports-gnome-42bad3fe54c824e861223ef1efa16fee85bd1e94.tar.gz
freebsd-ports-gnome-42bad3fe54c824e861223ef1efa16fee85bd1e94.tar.zst
freebsd-ports-gnome-42bad3fe54c824e861223ef1efa16fee85bd1e94.zip
- Support systems where pf(4) must be installed from ports (see
ports/67724, submitted by Michal F. Hanula) - Change ": foo=${foo:=bar}" into "foo=${foo:-bar}" to make the shell scripts easier to read and understand - Correct credits for the recently published NTLM auth vulnerability and fix a nearby braino, too - Bump PORTREVISION PR: ports/67797 Submitted by: maintainer
Diffstat (limited to 'www/squid30/Makefile')
-rw-r--r--www/squid30/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 8bc9b0833d32..70f66a13af59 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -29,7 +29,7 @@
PORTNAME= squid
PORTVERSION= 2.5.5
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -214,13 +214,12 @@ CONFIGURE_ARGS+= --enable-useragent-log
CONFIGURE_ARGS+= --enable-arp-acl
.endif
.if defined(WITH_SQUID_PF)
-.if ${OSVERSION} >= 502106
-# This will work only systems where PF is part of the base system for now.
-# If someone is eager to teach squid's configure script how to pick up the pf
-# port on 5.[0-2] systems instead, go on, I will integrate your patch.
CONFIGURE_ARGS+= --enable-pf-transparent
-.else
-IGNORE= WITH_SQUID_PF only works on systems where pf is part of the base system.
+.if ${OSVERSION} < 502106
+pf_includedir= ${LOCALBASE}/include/pf
+BUILD_DEPENDS+= ${pf_includedir}/net/pfvar.h:${PORTSDIR}/security/pf
+CFLAGS+= "-I${pf_includedir}"
+EXTRA_PATCHES+= ${WRKDIR}/pf_from_ports.patch
.endif
.endif
.if defined(WITH_SQUID_FOLLOW_XFF)
@@ -283,6 +282,15 @@ CONFIGURE_ARGS+= ${SQUID_CONFIGURE_ARGS}
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}"
+pre-patch:
+# Check whether we need to create the extra patch that makes pf(4)
+# visible for squid's configure script:
+.if defined(pf_includedir)
+ @${SED} -e 's|%%PF_INCLUDEDIR%%|${pf_includedir}|g' \
+ -e 's|%%PF_AC_INCLUDEPATH%%|${pf_includedir:S,/,_,g}|g' \
+ ${FILESDIR}/pf_from_ports.patch.in >${WRKDIR}/pf_from_ports.patch
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' ${WRKSRC}/doc/squid.8