aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid30/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-04-18 09:05:35 +0800
committerleeym <leeym@FreeBSD.org>2005-04-18 09:05:35 +0800
commitc634d71a669a2e7085f1d1a243d7d25fa3536248 (patch)
treeaf8cf172de5de2180266ace6c0091f9ea2309518 /www/squid30/Makefile
parent14fe5732bfef7d852ba79a4d717b7ed6a3e2633e (diff)
downloadfreebsd-ports-gnome-c634d71a669a2e7085f1d1a243d7d25fa3536248.tar.gz
freebsd-ports-gnome-c634d71a669a2e7085f1d1a243d7d25fa3536248.tar.zst
freebsd-ports-gnome-c634d71a669a2e7085f1d1a243d7d25fa3536248.zip
Integrate the following vendor patches as published on
<http://www.squid-cache.org/Versions/v2/2.5/bugs/>: - Correct several minor aufs issues (squid bug #671) - Basic authentification fails when login+password totalled to more than 64 characters (squid bug #1171) - Fix an assertion that could occur when traffic other than HTTPS was tunneled through squid via the CONNECT method (squid bug #1269) - Make the --disable-hostname-check configuration option actually work (squid bug #1270) - Fix aufs warning about open filedescriptors when the cache was shut down (squid bug #671) - Allow squid to process requests for files larger than 2GB in size (squid bug #437) Introduce a new OPTION "WITH_SQUID_LARGEFILE", default to off to match squid's default behaviour. Rebuild squid with -DWITH_SQUID_LARGEFILE or run 'make config' and select this new option. - Add two new cachemgr actions: "pending_objects" and "client_objects" - Make external acls that require authentication request new credentials after access had been denied (squid bug #1278) - Make squid use "daemon" instead of "local4" as syslog facility (squid bug #1227) PR: 80028 Submitted by: Thomas-Martin Seck <tmseck@netcologne.de> (maintainer)
Diffstat (limited to 'www/squid30/Makefile')
-rw-r--r--www/squid30/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 02b6a50758eb..4919f29a1b8f 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -66,7 +66,7 @@
PORTNAME= squid
PORTVERSION= 2.5.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -92,7 +92,16 @@ PATCHFILES= squid-2.5.STABLE9-setcookie.patch \
squid-2.5.STABLE9-ctype.patch \
squid-2.5.STABLE9-defer_digest_fetch.patch \
squid-2.5.STABLE9-dup_content_length.patch \
- squid-2.5.STABLE9-excess_data.patch
+ squid-2.5.STABLE9-excess_data.patch \
+ squid-2.5.STABLE9-aufs.patch \
+ squid-2.5.STABLE9-long_basic_auth.patch \
+ squid-2.5.STABLE9-CONNECT_truncated.patch \
+ squid-2.5.STABLE9-disable_hostname_checks.patch \
+ squid-2.5.STABLE9-aufs_shutdown.patch \
+ squid-2.5.STABLE9-2GB.patch \
+ squid-2.5.STABLE9-cachemgr_objects.patch \
+ squid-2.5.STABLE9-extaclauth.patch \
+ squid-2.5.STABLE9-syslog.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -135,6 +144,7 @@ OPTIONS= SQUID_LDAP_AUTH "Install LDAP authentication helpers" off \
SQUID_FOLLOW_XFF "Follow X-Forwarded-For headers" off \
SQUID_AUFS "Enable the aufs storage scheme" off \
SQUID_COSS "Enable the COSS storage scheme" off \
+ SQUID_LARGEFILE "Support log and cache files >2GB" off \
SQUID_STACKTRACES "Create backtraces on fatal errors" off \
SQUID_RCNG "Install an rcNG startup script" on
@@ -307,6 +317,9 @@ EXTRA_PATCHES+= ${PATCHDIR}/follow_xff-2.5.patch \
${PATCHDIR}/follow_xff-configure.patch
CONFIGURE_ARGS+= --enable-follow-x-forwarded-for
.endif
+.if defined(WITH_SQUID_LARGEFILE)
+CONFIGURE_ARGS+= --with-large-files --enable-large-cache-files
+.endif
.if defined(WITH_SQUID_STACKTRACES)
CONFIGURE_ARGS+= --enable-stacktraces
CFLAGS+= -g