aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2015-09-18 13:12:12 +0800
committercy <cy@FreeBSD.org>2015-09-18 13:12:12 +0800
commit0bef9b10e13addaf3832b337dc91c37491254475 (patch)
tree36aafcda3ea7d1aa4be7fa7be4bce027aed98a89 /www/squid
parent514de2dce8ccea92ee33d7fcd4ec326b26274cea (diff)
downloadfreebsd-ports-gnome-0bef9b10e13addaf3832b337dc91c37491254475.tar.gz
freebsd-ports-gnome-0bef9b10e13addaf3832b337dc91c37491254475.tar.zst
freebsd-ports-gnome-0bef9b10e13addaf3832b337dc91c37491254475.zip
Rather than produce a warning message that IPv6 is not supported
under ipfilter 4 (FreeBSD 9) every tenth time, reduce the message to one in a million. This has the effect of displaying the message at or shortly after startup with a reminder every blue moon. PR: 202950
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile2
-rw-r--r--www/squid/files/patch-src__ip__Intercept.cc15
2 files changed, 16 insertions, 1 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 6be48980ef40..387b4fb4b45d 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -2,7 +2,7 @@
PORTNAME= squid
PORTVERSION= 3.5.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ipv6
MASTER_SITES= http://www.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
http://www2.us.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
diff --git a/www/squid/files/patch-src__ip__Intercept.cc b/www/squid/files/patch-src__ip__Intercept.cc
new file mode 100644
index 000000000000..74d72b63a1b2
--- /dev/null
+++ b/www/squid/files/patch-src__ip__Intercept.cc
@@ -0,0 +1,15 @@
+--- src/ip/Intercept.cc.orig 2015-09-01 12:52:00.000000000 -0700
++++ src/ip/Intercept.cc 2015-09-17 21:52:44.892553613 -0700
+@@ -202,10 +202,10 @@
+ // for NAT lookup set local and remote IP:port's
+ if (newConn->remote.isIPv6()) {
+ #if IPFILTER_VERSION < 5000003
+- // warn once every 10 at critical level, then push down a level each repeated event
++ // warn once every million at critical level, then push down a level each repeated event
+ static int warningLevel = DBG_CRITICAL;
+ debugs(89, warningLevel, "IPF (IPFilter v4) NAT does not support IPv6. Please upgrade to IPFilter v5.1");
+- warningLevel = ++warningLevel % 10;
++ warningLevel = ++warningLevel % 1048576;
+ return false;
+ #else
+ natLookup.nl_v = 6;