aboutsummaryrefslogtreecommitdiffstats
path: root/www/squirm
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-06-23 07:20:04 +0800
committernox <nox@FreeBSD.org>2011-06-23 07:20:04 +0800
commit661559f1da68fec9d997440ee3794010023704a4 (patch)
tree9cb8745ea0e2036e9e5df5e8bf3c9a65be3ced3f /www/squirm
parent5f79a6984ac47bab98adc8a9498861bc09484286 (diff)
downloadfreebsd-ports-gnome-661559f1da68fec9d997440ee3794010023704a4.tar.gz
freebsd-ports-gnome-661559f1da68fec9d997440ee3794010023704a4.tar.zst
freebsd-ports-gnome-661559f1da68fec9d997440ee3794010023704a4.zip
Fix build with clang.
PR: ports/158177 (after fixing a typo :) Submitted by: Niclas Zeising <niclas.zeising@gmail.com>
Diffstat (limited to 'www/squirm')
-rw-r--r--www/squirm/Makefile2
-rw-r--r--www/squirm/files/patch-squirm.c11
2 files changed, 13 insertions, 0 deletions
diff --git a/www/squirm/Makefile b/www/squirm/Makefile
index badaf849cdc4..b9c889fdc5c0 100644
--- a/www/squirm/Makefile
+++ b/www/squirm/Makefile
@@ -16,6 +16,8 @@ COMMENT= A fast & configurable redirector for the Squid
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
+USE_CSTD= gnu89
+
SQUID_UID?= squid
SQUID_GID?= squid
diff --git a/www/squirm/files/patch-squirm.c b/www/squirm/files/patch-squirm.c
new file mode 100644
index 000000000000..c3cd74e775a8
--- /dev/null
+++ b/www/squirm/files/patch-squirm.c
@@ -0,0 +1,11 @@
+--- squirm.c.orig 2011-06-23 00:02:30.000000000 +0200
++++ squirm.c 2011-06-23 00:02:46.000000000 +0200
+@@ -88,7 +88,7 @@
+ print buff to stdout
+ */
+ if(strlen(in_buff->url) <= 4) {
+- logprint(LOG_FAIL, "strlen in_buff->url = [%d] in main()\n",
++ logprint(LOG_FAIL, "strlen in_buff->url = [%zu] in main()\n",
+ strlen(in_buff->url));
+ return 1;
+ }