aboutsummaryrefslogtreecommitdiffstats
path: root/www/srg
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2004-07-01 16:30:35 +0800
committerosa <osa@FreeBSD.org>2004-07-01 16:30:35 +0800
commit5832930a5c2c0432c308aed66078ebbcbd7ce407 (patch)
tree4c51f14afc035700adbf591095f056213b530a1b /www/srg
parentacee9a60c943d1b385537d739a58005f1de7d076 (diff)
downloadfreebsd-ports-gnome-5832930a5c2c0432c308aed66078ebbcbd7ce407.tar.gz
freebsd-ports-gnome-5832930a5c2c0432c308aed66078ebbcbd7ce407.tar.zst
freebsd-ports-gnome-5832930a5c2c0432c308aed66078ebbcbd7ce407.zip
Fix build under 4.x by use USE_GETOPT_LONG.
Notice from: kris and bento
Diffstat (limited to 'www/srg')
-rw-r--r--www/srg/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/www/srg/Makefile b/www/srg/Makefile
index a6647ace872b..90a8a632d160 100644
--- a/www/srg/Makefile
+++ b/www/srg/Makefile
@@ -19,8 +19,10 @@ USE_GMAKE= yes
USE_BISON= yes
USE_BZIP2= yes
USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
NO_INSTALL_MANPAGES= yes
-MAKE_ENV= CC="${CC}" CXX="${CXX}"
+MAKE_ENV= CC="${CC}" CXX="${CXX}" \
+ CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/srg
.for i in footer.php header.php ip2user.txt srg.conf
@@ -29,8 +31,9 @@ PLIST_FILES+= share/examples/srg/${i}
PLIST_DIRS= share/examples/srg
post-patch:
- ${REINPLACE_CMD} -e 's|-g |${CFLAGS} |' ${WRKSRC}/Makefile \
+ ${REINPLACE_CMD} -e 's|-g |${CFLAGS} ${CPPFLAGS} |' ${WRKSRC}/Makefile \
${WRKSRC}/lib/Makefile
+ ${REINPLACE_CMD} -e 's|^\(LDFLAGS\)=|\1+=|' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/srg ${PREFIX}/bin