aboutsummaryrefslogtreecommitdiffstats
path: root/www/thundercache
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2010-03-19 02:35:20 +0800
committergarga <garga@FreeBSD.org>2010-03-19 02:35:20 +0800
commit314ad4a9580a64ae47b36ebf694ebeb922c0b3b8 (patch)
tree551af4d46340a340d394915bd8150630fb4c0016 /www/thundercache
parentfd59b81495cd00bca80c991b615bebaa0cf73d8b (diff)
downloadfreebsd-ports-gnome-314ad4a9580a64ae47b36ebf694ebeb922c0b3b8.tar.gz
freebsd-ports-gnome-314ad4a9580a64ae47b36ebf694ebeb922c0b3b8.tar.zst
freebsd-ports-gnome-314ad4a9580a64ae47b36ebf694ebeb922c0b3b8.zip
ThunderCache 4 is an enhaced standalone high-performance web caching system.
It's main goal is to be able to cache dynamic contents, the content most proxing systems are unable to do caching. This is how ThunderCache becomes high-performance and high-eficiency. ThunderCache is freeware up to 50 concurrent sessions, and needs commercial license to run more than 50 concurrent sessions. It's designed to run on FreeBSD. Advanced features include TProxy support (IP_BINDANY), ToS/DiffService marking. WWW: http://www.bmsoftware.org Submitted by: Patrick Tracanelli <eksffa at freebsdbrasil.com.br> (by email)
Diffstat (limited to 'www/thundercache')
-rw-r--r--www/thundercache/Makefile82
-rw-r--r--www/thundercache/distinfo6
-rw-r--r--www/thundercache/files/log.sh.in27
-rw-r--r--www/thundercache/files/pkg-message.in39
-rw-r--r--www/thundercache/files/thunder-rcNG.in21
-rw-r--r--www/thundercache/pkg-descr12
-rw-r--r--www/thundercache/pkg-plist65
7 files changed, 252 insertions, 0 deletions
diff --git a/www/thundercache/Makefile b/www/thundercache/Makefile
new file mode 100644
index 000000000000..39df9465baa0
--- /dev/null
+++ b/www/thundercache/Makefile
@@ -0,0 +1,82 @@
+# New ports collection makefile for: thundercache
+# Date created: 2010-03-15
+# Whom: Patrick Tracanelli <eksffa@freebsdbrasil.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thundercache
+PORTVERSION= 4.0
+CATEGORIES= www
+MASTER_SITES= http://www.bmsoftware.org/freebsd/ \
+ http://www6.freebsdbrasil.com.br/~eksffa/l/dev/thunder/ \
+ ${MASTER_SITE_LOCAL}/jmelo
+DISTNAME= thunder32bits_17032010
+
+MAINTAINER= eksffa@freebsdbrasil.com.br
+COMMENT= High-performance and high-eficiency caching proxy system
+
+OPTIONS= DEPENDACK "I have read and understood the depends needs" off
+
+USE_OPENSSL= yes
+USE_BZIP2= yes
+
+ONLY_FOR_ARCHS= i386 amd64
+
+NO_BUILD= yes
+LICENSE= shareware / commercial
+RESTRICTED= Commercial software with shareware license to 50 threads
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800000
+BROKEN= Won't run on systems version < FreeBSD 8.0-RELEASE
+.endif
+
+.if ${ARCH} == "amd64"
+DISTNAME= thunder64bits_17032010
+.endif
+
+WRKSRC= ${WRKDIR}/thunder
+
+USE_PHP+= curl pcre bcmath pdo mcrypt mhash session pgsql
+USE_PGSQL= yes
+WANT_PGSQL_VER= 84
+USE_APACHE= 2.0+
+
+LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl:install
+RUN_DEPENDS+= sudo:${PORTSDIR}/security/sudo \
+ postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server \
+ ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
+
+SUB_FILES= pkg-message thunder-rcNG log.sh
+
+pre-everything::
+.if !defined(WITH_DEPENDACK)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "ATTENTION:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " It is very important that you carefully read and respect"
+ @${ECHO_MSG} " the special build options for the following depends:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " ftp/curl LIBSSH2=yes OPENSSL=yes PROXY=yes"
+ @${ECHO_MSG} " security/openssl ZLIB=yes"
+ @${ECHO_MSG} " devel/php5-pcre BUNDLED_PCRE=yes (for apache20)"
+ @${ECHO_MSG} " postgresql${PGSQL_VER}-server \
+ NLS=yes PAM=yes OPTIMIZED_CFLAGS=yes TZDATA=yes"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " After you understood it correctly, select DEPENDACK on"
+ @${ECHO_MSG} " the OPTIONS screen. Run ''make config'' to acknowledge"
+ @${ECHO_MSG} ""
+ @${FALSE}
+.endif
+
+do-install:
+ @${CP} -r ${WRKSRC} ${PREFIX}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/thunder-rcNG ${PREFIX}/etc/rc.d/thunder
+ ${INSTALL_SCRIPT} ${WRKDIR}/log.sh ${PREFIX}/thunder/sbin/
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/thundercache/distinfo b/www/thundercache/distinfo
new file mode 100644
index 000000000000..0b3179034607
--- /dev/null
+++ b/www/thundercache/distinfo
@@ -0,0 +1,6 @@
+MD5 (thunder32bits_17032010.tar.bz2) = 83a1c3319f50b30e9c126efe446218f6
+SHA256 (thunder32bits_17032010.tar.bz2) = 49a310295360feba0fda20ef043d861a4769b30c57f2fe14c046ea4d40d3f7e0
+SIZE (thunder32bits_17032010.tar.bz2) = 2729811
+MD5 (thunder64bits_17032010.tar.bz2) = ef1af778432abe887033b503a2ba6bdc
+SHA256 (thunder64bits_17032010.tar.bz2) = 4ab6b36159ac1b25855feb70a933a96fb750ea6a81306c026dceae0cc8081535
+SIZE (thunder64bits_17032010.tar.bz2) = 3870257
diff --git a/www/thundercache/files/log.sh.in b/www/thundercache/files/log.sh.in
new file mode 100644
index 000000000000..d50f058e608a
--- /dev/null
+++ b/www/thundercache/files/log.sh.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+export PATH="/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin"
+#
+# Patrick Tracanelli <eksffa@freebsdbrasil.com.br>
+#
+# Config
+#
+PHP="%%PREFIX%%/bin/php"
+THUNDERLOG="%%PREFIX%%/thunder/sbin/thunderlog.php"
+DB="thunder"
+HOST="localhost"
+USER="thunder"
+PASS="thundercache"
+LOG="%%PREFIX%%/thunder/logs"
+LOGTEMP="%%PREFIX%%/thunder/logs/tmp"
+SCRIPTLOG="/dev/null" # mude para /tmp/scriptlog.log para debugar se preciso
+
+#
+# Simply populate some stats andresets access.log
+#
+
+cp -f ${LOG}/access.log ${LOGTEMP}/access.log
+
+:> ${LOG}/access.log
+
+$PHP $THUNDERLOG $HOST $DB $USER $PASS $LOGTEMP/access.log >>$ {SCRIPTLOG} 2>&1 && rm -f $LOGTEMP/access.log
+
diff --git a/www/thundercache/files/pkg-message.in b/www/thundercache/files/pkg-message.in
new file mode 100644
index 000000000000..200de3f40492
--- /dev/null
+++ b/www/thundercache/files/pkg-message.in
@@ -0,0 +1,39 @@
+
+Please note that you have just installed ThunderCache 4 on
+
+ %%PREFIX%%/thunder
+
+Now you have to configure your system according to these instructions:
+
+Enable PostgreSQL database and set a special login class o rc.conf:
+
+ postgresql_enable="YES"
+ postgresql_class="postgres"
+
+Create the special login class on login.conf:
+
+ postgres:\
+ :lang=en_US.UTF-8:\
+ :setenv=LC_COLLATE=C:\
+ :tc=default:
+
+Update the login database:
+
+ cap_mkdb /etc/login.conf
+
+Create the needed database:
+
+ %%PREFIX%%/bin/psql postgres -U pgsql < \
+ %%PREFIX%%/thunder/etc/thunder_postgre.sql
+
+Copy %%PREFIX%%/thunder/etc/thunder.php to some adequated place, like:
+
+ cp -p %%PREFIX%%/thunder/etc/thunder.php \
+ %%PREFIX%%/www/data/
+
+Add %%PREFIX%%/thunder/sbin/log.sh to /etc/crontab according to your needs:
+
+ @hourly root %%PREFIX%%/thunder/sbin/log.sh
+
+Configure %%PREFIX%%/thunder/etc/thunder.conf accordingly.
+
diff --git a/www/thundercache/files/thunder-rcNG.in b/www/thundercache/files/thunder-rcNG.in
new file mode 100644
index 000000000000..901fe1fb8b27
--- /dev/null
+++ b/www/thundercache/files/thunder-rcNG.in
@@ -0,0 +1,21 @@
+#!/bin/sh
+#
+# PROVIDE: thunder
+# REQUIRE: LOGIN
+#
+# Remember to thunder_enable="YES" in /etc/rc.conf
+#
+# FreeBSD Brasil LTDA <consultoria@freebsdbrasil.com.br>
+#
+
+. /etc/rc.subr
+
+name="thunder"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/thunder/sbin/thunder ${thunder_flags}"
+pidfile="/var/run/thunder/thunder.pid"
+: ${thunder_enable="NO"}
+: ${thunder_flags="-c %%PREFIX%%/thunder/etc/thunder.conf"}
+load_rc_config $name
+run_rc_command "$1"
+
diff --git a/www/thundercache/pkg-descr b/www/thundercache/pkg-descr
new file mode 100644
index 000000000000..6bec01d7ab4b
--- /dev/null
+++ b/www/thundercache/pkg-descr
@@ -0,0 +1,12 @@
+ThunderCache 4 is an enhaced standalone high-performance web caching system.
+
+It's main goal is to be able to cache dynamic contents, the content most
+proxing systems are unable to do caching. This is how ThunderCache becomes
+high-performance and high-eficiency.
+
+ThunderCache is freeware up to 50 concurrent sessions, and needs commercial
+license to run more than 50 concurrent sessions. It's designed to run on
+FreeBSD. Advanced features include TProxy support (IP_BINDANY), ToS/DiffService
+marking.
+
+WWW: http://www.bmsoftware.org
diff --git a/www/thundercache/pkg-plist b/www/thundercache/pkg-plist
new file mode 100644
index 000000000000..7ace64171949
--- /dev/null
+++ b/www/thundercache/pkg-plist
@@ -0,0 +1,65 @@
+thunder/etc/thunder.conf
+thunder/etc/log.sh
+thunder/etc/thunder.php
+thunder/etc/thunder_postgre.sql
+thunder/logs/error.log
+thunder/logs/access.log
+thunder/plugins/4shared.com.so
+thunder/plugins/avast.com.so
+thunder/plugins/avg.com.so
+thunder/plugins/avgate.com.so
+thunder/plugins/avgate.net.so
+thunder/plugins/bitgravity.com.so
+thunder/plugins/dailymotion.com.so
+thunder/plugins/doubleclick.net.so
+thunder/plugins/edgecastcdn.net.so
+thunder/plugins/eset.com.so
+thunder/plugins/etrustdownloads.ca.com.so
+thunder/plugins/freeav.com.so
+thunder/plugins/freeav.net.so
+thunder/plugins/globo.com.so
+thunder/plugins/sambatech.com.br.so
+thunder/plugins/googlevideo.com.so
+thunder/plugins/grandchase.com.br.so
+thunder/plugins/grisoft.com.so
+thunder/plugins/nai.com.so
+thunder/plugins/grisoft.cz.so
+thunder/plugins/kaspersky-labs.com.so
+thunder/plugins/kaspersky.com.so
+thunder/plugins/mccont.com.so
+thunder/plugins/mediafire.com.so
+thunder/plugins/megaupload.com.so
+thunder/plugins/megavideo.com.so
+thunder/plugins/metacafe.com.so
+thunder/plugins/microsoft.com.so
+thunder/plugins/orkut.com.br.so
+thunder/plugins/orkut.com.so
+thunder/plugins/photobucket.com.so
+thunder/plugins/pop6.com.so
+thunder/plugins/pornhub.com.so
+thunder/plugins/pornotube.com.so
+thunder/plugins/rad.msn.com.so
+thunder/plugins/rapidshare.com.so
+thunder/plugins/redtube.com.so
+thunder/plugins/symantecliveupdate.com.so
+thunder/plugins/terra.com.so
+thunder/plugins/tube8.com.so
+thunder/plugins/uol.com.br.so
+thunder/plugins/update.nai.com.so
+thunder/plugins/viddler.com.so
+thunder/plugins/video.msn.com.so
+thunder/plugins/vimeo.com.so
+thunder/plugins/windowsupdate.com.so
+thunder/plugins/xtube.com.so
+thunder/plugins/xvideos.com.so
+thunder/plugins/youtube.com.so
+thunder/plugins/ziddu.com.so
+thunder/sbin/thunder
+thunder/sbin/thunderlog.php
+thunder/sbin/log.sh
+@dirrm thunder/etc
+@dirrm thunder/logs/tmp
+@dirrm thunder/logs
+@dirrm thunder/plugins
+@dirrm thunder/sbin
+@dirrm thunder