aboutsummaryrefslogtreecommitdiffstats
path: root/www/tomcat55
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-08-20 16:56:50 +0800
committermiwi <miwi@FreeBSD.org>2007-08-20 16:56:50 +0800
commitf67003b9a7c70f26d35acf12b568dda7b262af53 (patch)
tree359abba976017e5428c10b7576786dc737e4f0e1 /www/tomcat55
parent6b33ddaa08b2e94ce15288ea0fc478b2e3063211 (diff)
downloadfreebsd-ports-gnome-f67003b9a7c70f26d35acf12b568dda7b262af53.tar.gz
freebsd-ports-gnome-f67003b9a7c70f26d35acf12b568dda7b262af53.tar.zst
freebsd-ports-gnome-f67003b9a7c70f26d35acf12b568dda7b262af53.zip
- Set ownership $TOMCAT_HOME/webapps directory to $TOMCAT_USER:$TOMCAT_GROUP [1]
- While upgrading www/tomcat55 port, if there any directories with spaces in their names within $TOMCAT_HOME/webapps or $TOMCAT_HOME/work directories, setting up permissions fail. Rewrite the "Fixing permissions" loop. [2] PR: 115463 Gabor Tjong A Hung <g.v.tjongahung@gmail.com> [1] Alexey Rubtsov <arubtsov@swsoft.com> [2] Approved by: Tomas Verbaitis <tomasv@megalogika.lt> (maintainer):x
Diffstat (limited to 'www/tomcat55')
-rw-r--r--www/tomcat55/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/www/tomcat55/Makefile b/www/tomcat55/Makefile
index 642f3dd6519a..e53413fd869a 100644
--- a/www/tomcat55/Makefile
+++ b/www/tomcat55/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.23
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-5/v${PORTVERSION}/bin
@@ -129,10 +129,13 @@ do-install:
@${ECHO_MSG} -n ">> Fixing ownership settings..."
@${CHOWN} -R ${TOMCAT_USER}:${TOMCAT_GROUP} ${APP_HOME}/conf ${APP_HOME}/logs \
- ${APP_HOME}/temp ${APP_HOME}/work
+ ${APP_HOME}/temp ${APP_HOME}/work ${APP_HOME}/webapps
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Fixing permissions..."
+ @${FIND} ${APP_HOME} -type d | while read a; do\
+ ${CHMOD} 755 "$$a"; \
+ done
@${CHMOD} 755 `${FIND} ${APP_HOME} -type d`
@${ECHO_MSG} " [ DONE ]"